Gmod isnt starting

when i try to launch it it says preparing to launch Garry’s mod… after that the box dissapears and nothing happens.

UPDATE! when i launched it sayed i was in game then i wasent

Try running the game with -fullscreen

nothing

[editline]06:53AM[/editline]

well i tried playing day of defeat source and it runs fine. gmod is broken in my opinion i bought it through steam so its not because i illegally DL’ed it

Rename garrysmod to garrysmodold and see if it starts

i tryed like a minite ago and still nothing

open your task manager,(ctrl, alt, delete; click on start task manager) click on processes, and it will show hl2.exe is running, end the task, then it will work
happens to new windows 64 bits… i think lol
but it happens to me, so i just keep my task manager up the whole time
hope this helps

hl2.exe isnt their

i got some problems too.
in my case i can start it but it is loading forever!
today i wanted to install it new but it doesnt uninstall.
when i make a right klick on garrys mod in my steam library and then on delete lokal data. then there appears another window which asks me if i really want to delete it. then i klick on the button delete but the only thing that happens is that the window and the shortcut on my desktop dissapear.
does somebody got an idea how to solve this problem?

HEY this is MY thread dount post youre problems here make youre onw please

sorry man
then tell me how to delete the post

Could you link us to a working Steam Community profile so we have some sort of proof that you actually bought the game.

Is searching for names in Steam really that hard?
Yes, he does own GMod.

[editline]13:37[/editline]

Try putting this in launch options:


-window -w *x* -h *y* -noborder

Where you would replace x and y with your native resolution’s width and height respectively.
If that doesn’t work, trying adding “-dxlevel 90” to launch options.

[editline]13:38[/editline]

He has ~500 hours on record for GMod, so, assuming that he’s not trying to play it on a different computer, specs are not an issue.

OP post specs.

I’m pretty sure this bug occurs when the game is trying to launch in a non-native resolution. I had it happen after I deleted Lost Coast’s registry and it was trying to launch in 1024x768 (but my monitor’s native resolution was 1280x1024).

You could try registry editing.

Click Start > Run… > Type in “regedit” (without quotes) > OK

Registry Editor should open.

Navigate to HKEY_CURRENT_USER\Software\Valve\Source\garrysmod\Settings

Find ScreenWidth and ScreenHeight or your right.

Set them to your monitor’s native width and native height (respectively).

Launch Garry’s Mod.

Let us know if it worked.

thanks of the advice but nothing worked :frowning: i think gmod’s broken