GMod just doesn't launch

it dont work and ive tried everything

i tried verifying cache, deleting the folders, reinstalling, in any order you want. and yet trying to launch garry’s mod just tells me that hl2.exe has stopped responding.

also i tried launching in textmode but apparently nothing is written in the console before it crashes.
so does anybody have an idea???

Mind posting your computer specs?

Processor: AMD Phenom II X4 955 processor, ~3.2 GHZ
1300 gb of HDD space
GPU: Ati Radeon Sapphire 5770 HD
4gb of memory

i don’t see how this wouldn’t be able to run gmod seeing as my previous (worse) computer could run it without problems??

dxlevel ???

Since its a 5770 probably 11 derp

have you used the opening command “dxlevel-100” “dxlevel-90” “dxlevel-81”??? try it with one of those.

Mine crashes when loading post init systems. Got a fix for that? The dxlevel doesnt affect it at all.

The different directX levels did nothing.

maybe its because of the updates lately…or video card needs updating.

actually, i got it to work.

i maintain my point that garry is very bad at this, though.

No reason to change your point.

Wanna tell me what did you do?

All i’ve found out about my problem which is prety similiar, is that the filesystem_steam.dll is causing it.



Viallisen sovelluksen nimi: hl2.exe, versio: 0.0.0.0, aikaleima: 0x4d094ebe
Viallisen moduulin nimi: filesystem_steam.dll, versio: 0.0.0.0, aikaleima: 0x4d0a5da7
Poikkeuskoodi: 0xc000000d
Virhepoikkeama: 0x0002db2d
Viallisen prosessin tunnus: 0x334
Viallisen sovelluksen käynnistysaika: 0x01cba9310573e77a
Viallisen sovelluksen polku: c:\program files (x86)\valve\steam\steamapps\username\garrysmod\hl2.exe
Viallisen moduulin polku: c:\program files (x86)\valve\steam\steamapps\username\garrysmod\bin\filesystem_steam.dll
Raportin tunnus: 4b0e0afa-1524-11e0-9b2d-028037ec0200


Vikasäiliö 1577580930, tyyppi 5
Tapahtuman nimi: BEX
Vastaus: Ei käytettävissä
Cab Id: 0

Ongelman allekirjoitus:
P1: hl2.exe
P2: 0.0.0.0
P3: 4d094ebe
P4: filesystem_steam.dll
P5: 0.0.0.0
P6: 4d0a5da7
P7: 0002db2d
P8: c000000d

And of course the file can’t be replaced because the garrysmod will replace it with the one from CFG files, and you can’t edit the CFG files, and the CFG files are valid… Thus resulting in big “fuck you” from the one named newman.