Gmod keep maximizing and minimizing

And I don’t want to go vanilla to fix this problem.

Help would be nice.

Something interrupting it in the background?

Are you running Vista or Windows 7? I am and that happens to me with a lot of programs. Create a shortcut to GMod, right click, go to properties, then compatibility. Check “disable visual themes” and “disable desktop composition”.