gmod launcher error

this has only happened recently and its very fustrating

i started up my computer and signed into steam and started loading gmod, then the box disapeared and another box came up saying
Failed to load the launcher DLL:
%1 is not a valid Win32 application

ive tried restarting steam, deleting my gmod folder (well renaming it to sommin else) but it wont work
what shuld i do

I have the same problem, I tried everything you did and still no results. Hope this gets fixed soon.

i also made a thread like this and i have the same problem, (posted in wrong forum,sry) people told me to ensure i had the latest .NET framework (4.0) or replace the hal.dll folder and im doing stuff right now u should also try to do that.and download a free registry cleaner to check if there are any errors in ur hal.dll file

ok i will try the suggestions above, at least i am nt the only one with this problem

Re-install steam… backup your addons if you care…
Also, don’t join the PERP server with fake players…

What is the PERP thing? (Thats how this happened, I joined that server.)

It’s a virus server.

is the PERP server a RP server?
cause i only go on them

The real PERP server is RP, the fake one with fake player slots etc is a virus server

i went on the real server but nt the fake one
i might try deleting everythin in my garrysmod folder (the first garrysmod folder not the second one)


it worked! im a genius!
i simply deleted the folder then went onto gmod and its fine :smiley:

I’m pretty sure some of us told you to try that… the problem is probably within garrysmod and / or garrysmod/bin

Funny there is a file called launcher.dll in username/garrysmod/bin uh?

dnt think any1 told me it but i also thought tht it was strange that a file was called bin…

The same thing happened to me, I joined a fake server, it crashed the game, I had to re-install it and then I got the error about a launcher. I checked the bin folder and found a file which was not created on the same day I installed garry’s mod, the file was called wsock 32, once I deleted it Garry’s mod started working again. I’m assuming it will work for anyone else.

Yeah i have the same problem :frowning: thought it would be a good buy seeing as i loved all the other valve games.
But i have tried every thing u have already suggested excppept reinstalling steam. and still nothing seems to get rid of the problem :confused: and my comp dosent find any hal.dll files
dont rather fancy reinstalling all my games i have cause it took so long to download them all. any one got any more ideas?

I also had this problem. I fixed it by renaming my bin folder in C:\Program Files\Steam\steamapps[YOUR-USERNAME]\garrysmod\

To something different, then running the game. If you do this, Garry’s Mod will think that the bin folder doesn’t exist and generate a new one without the corrupted file!

Just rename the bin folder to like “bin2” or something. You can delete it if Garry’s Mod starts fine.

I’m going to dub this the perp worm just because no one else has. I think there’s a more worm aspect to it, for the reason that people who were affected by this worm connected to an RP server I frequent. Now, somewhat randomly the server reconnects people to another server running gm_construct, and then to another running flatgrass. I luckily managed to stop it from happening by hard restarting my computer, however those who didn’t and just let it connect had the same problems and the fix did work. So if this happens, I suggest checking your server’s bin folder for the same file.

This just happend to me, the same exact thing. Fixed it by deleting the wsock file. I was in my favorite roleplay server when my garrysmod started connecting to those servers. I hope Garry looks into this, probably an exploit of some sort.

I think the easiest way to fix this is to make a blank txt document and rename it to the winsock file. That way it won’t redownload. That is unless the creator reads this and changes it but it should work for a while until the script kiddie gets to work on rev 2 and hopefully it should last until team garry patches it.


Ok, it seems that the wsock file isn’t on servers. So I have no idea why this would be happening, maybe another file?

And could someone post the exact file name of the wsock file?

Also, I’m no professional but these following files were added to my bin folder today at 6 pm “MenuSystem.dll, server.dll SceneCacheProxy.dll, lua-shared.dll client.dll and game_shader_generic_garrysmod.dll” does anyone else have those? Is it a gmod update or could they be part of the worm?

I just find it a little odd that they would be added today when all the other .dll’s were added when I installed gmod, and that I haven’t joined any other gmod servers except my usual RP server and the perp server, nor has gmod been updated since feb the 15th…

The exact filename is wsock32.dll, I opened the file with notepad and its all gibberish except for a few file names and words hidden in the text, and some random parts of addons like stacker, wire touch plate, etc.

I also could not find the extra files that you mentioned in my bin folder.

[editline] lol [/editline]

The addons listed inside the file are random and usually have nothing to do with each other, anyways most of the file is unreadable, unless somebody knows a dll reader that turns that gibberish into plain code.

Ok, I’ve just discovered something. Do not create a fake wsock32.dll file in either bin folder. even though it’s fake, I believe the presence of it tells gmod to use that dll instead of the provided windows one.

The only way this can be fixed is to have team garry patch it.