Gmod not launching

Alright, so I keep on trying to start gmod, but every time I do, steam says, “Preparing to launch Gmod”, then it closes, and nothing happens. I keep on double clicking the shortcut, and I get the same thing. I have tried re-logging into steam, and restarting my system. Could this possibly be a .lua virus?

EDIT:

System hardware specs

  • Processor: Intel Core Duo P8700 @ 2.53GHz
  • RAM: 6.00 GB
  • Graphics Card: Nvidia Geforce GTX 260M 1GB
  • Operating System: Windows Vista Home Premium

EDIT (again):
Ok, I REALLY need some help I’ve been wanting to play GMod for ages! dose ANYONE have a solution?

EDIT (again again):
FUCK YEAH! It just randomly started working!

try clean reinstalling gmod, could be a problem with an addon. also, add your system specs

Well, It worked perfectly fine since the last time i played GMod, and I haven’t installed any addons since.

Really cant tell you much without your system specs

check the top post. I edited it in shortly after my last reply.

Edit:

Renamed my gmod folder to remake it, and still, it fails to launch.

Try renaming your ClientRegistry.blob file within “Program Files/Steam” to something else, such as, ClientRegistry2.blob.

Turn off steam commuity ingame. Try that…

Didn’t work.

Nope. Not this either.

There was an update just now I think.

update didn’t do shit. D:

Try following the directions within this Steam knowledge base article.

That’s for if it says “this game is unavailable”. It’s not even saying that. It just closes when it’s done preping.

bump

are all of your drivers up to date?

I would think so. I’m not sure how long it takes for them to be outdated, but my computer is less then a year old.

damn it! Can ANYONE help me?

EDIT:
FUCK YEAH! It just randomly started working!

once i was playing gmod and the next day it said “you dont have garrys mod 10”