Gmod not launching

Every time I try to launch Gmod, it shows the Steam launching window for a few seconds and says I’m in-game and then it crashes with no error without actually launching the game. I have no Idea what it could be, I tried re-installing, deleting all my addons, everything and nothing worked. Any ideas?

Are you using the new Steam UI?

I was and Gmod wasnt working, But i changed back and it was

[editline]09:58AM[/editline]

Just tried it again, Not workin

Yes I am, are you saying that’s the problem?

It still isn’t working, but thanks for trying.

I just tried removing any addons ive installed in the past few days…

Still not working so i tried to launch from hl2.exe inside the gmod folder…

Get the error “Setup File ‘Gameinfo.txt’ does not exist”

I don’t even get an error, it says I’m ingame to my friends for 5-10 seconds without actually launching and then it “crashes” (in quotes because it never launches) and it says I’m not anymore.

Had same problem, I fixed it…

Are you running XP or Vista or Windows 7?

Specs, please.

Try adding -windowed -dxlevel 80 to the launch options.

i have the exact same problem and i tried everything with the codes to even changed graphic card 3 times and cpu but doesn´t work :stuck_out_tongue: so il post if i find a way…

He recently got rid of a rootkit virus, if that helps any.

well i found out that its not just gmod making problems its all the other games to… tried CSS and TF2 :confused: neither work well tf2 comes up to the screen with the VALVE thingie then it crashes >>

ba-dump-bump

I’m going to try all of this in the morning, I’m tired now.
I’m running XP and I did semi-recently remove a rootkit from my computer as noobcake said.

[editline]11:30PM[/editline]

Specs when I can be assed to wake up and do something

[editline]11:31PM[/editline]

also i have removed every addon and re-installed the game, both did jack shit

[editline]11:31PM[/editline]

oops already said that in OP

[editline]11:32PM[/editline]

ok really going to bed now