Gmod not registering horizontal mouse movement

However, vertical mouse movement works fine!
I can move around and look fine, but as soon as I E+Mouse something to rotate it, it will only want to rotate to vertical mouse movement.
Another situation where this happens is in Tiramisu in Thirdperson (I had another friend test and he said its working fine for him), where again, it only registers vertical mouse movement and not horizontal.
My mouse is fine and works normally while looking around in Gmod.

I’ve had a look around but it doesn’t appear to be a common problem.
Anyone know a fix for this?

Bump :s

One more, this really fucks with my gameplay.
Anyone know what this could be?
I reinstalled my garrysmod to no avail.

Probably a console variable that you may have changed

Is it possible to reset all console variables to default?

re install the game? I checked and there were no con commands i could find that would effect horizontal movement.

type m_pitch 0 and m_yaw 0 in the console

[editline]28th January 2013[/editline]

actually i think the default might be .022 I’m not sure, dev wiki says 0 but other sources say .022, I’m thinking .022 is correct because 0 seems like it would multiply the sens by 0 resulting in no movement (x * 0 = 0)

Tried both, they affected my “looking around”, but not rotating with E+Mouse.

Tried a complete redownload of Gmod, to no avail.
Its appears to only happen in Singleplayer and on MY server.