GMOD on Vista

Iv’e Google d the f’n problem and i still cant figure out what to do. None of the mods i download will work on Garry’s mod. I got a new computer that has Vista and Vista is a fucking piece of shit nothing ever works right with it. So how do i get mods to work with Vista.

Saying you’ve got Vista and mods are not working does not really give us much to work with.

Your descriptions are so helpful.

I can play the game i downloaded a bunch of mods and stuff and i put them in the folder where they are supposed to be and none of them show up when i play

Read the instructions? Do you know what you’re doing? I only play GMOD on Vista, no mod/map issues here.

Ive had gmod for a couple of years and it worked fine on my old computer it was and XP. The reason i say that vista is the problem is because i had the same problem with fallout 3 and its mods but i fixed it some how

[editline]04:16PM[/editline]

But ive tried disabling all that gay security shit that vista has and it dosent help like it did for fallout 3

i have no problems with addons and maps on vista home basic

Ok i have vista aswell,i had the same problum.Ok theres ALOT of ways you could mess this up,but its really simple.

Say you wanted to get the multi no collide tool.First make sure you have winrar.When the file opens in winrar it should have 2 File … & Multi no collide/Custum names (always only 2 folders … and/? ok but not right click on the file thats not … and click Extract.It will need a file locaaton or one will be made by itself,You have you get to the addons folder for gmod

I assume you know how to get there

When in addons right click off to the right side of the adress bar thing,It should turn blue and become letters when its blue right click and copy.Paste it in the directey find that you opend in wir rar

then go back to your addons,and make sure your mod is in that folder

if it is it probaly WILL work.Some addons requice it to be in the garrys mod garrysmod folder

Have fun and i hope ive helped

[editline]09:19PM[/editline]

Why dont you guys stop telling him how good your doing and help him? if your not solving the propl;um leave him Alone guys

[editline]09:22PM[/editline]

Wow someone rates my comment dumb when i’m the first person to even TRY to help him

Im working on it ill tell you if it works

You’re just a fucking idiot. Try disabling UAC

or just go back to your “user friendly XP”

I have vista, brand new laptop. I have yet to have one problem. Maybe…just maybe…Its you at fault. Its hard to see the problem through all your flaming.

Ok didnt work

[editline]04:44PM[/editline]

Your just a fucking douche bag and i do have UAC disabled

[editline]04:46PM[/editline]

I had the same problem with fallout3 i disabled uac and it worked but its not working for gmod

don’t blame Vista.

I use Vista, and have yet to have one problem.

Here is how to install Tool’s that are in addon format*.

Say you are installing Conna’s Tool Pack

  1. download the Pack.
  2. find where the stuff was downloaded to.
  3. extract the stuff.
  4. drag the files you extracted to this location;

C:\Program Files\Steam\steamapps*your username*\garrysmod\garrysmod\addons

afterwards, if you open up the addons folder, you should see “Conna’s Tools Pack”

If you don’t, you did it wrong. Try again until you do it right.

Once you’ve done it right, load up GMod, start a single player game (any map you want).

Once it finishes loading, go to your tool list, and look for the section with the word “Conna” in it.

When you find it, click on any of the tools listed. You will equip it, and be able to use it for what ever the propose is!

Now for entities!

Do ever thing the same as with tools, and once you load up GMod, the object will be under the entity tab!

As for props (like PHX), again, go everything from before, and then look under the “Prop” tab (it should be the first tab), and find the list of props for that pack.

And as for NPC’s, guess what, they show up under the NPC tab! (gasp)

There, now you can stop being a little douche bag kid, accept that Vista doesn’t cause every problem ever in existence ever, and play GMod.

Also, if you install Wiremod, and can’t understand it, don’t blame Vista, blame the fact that Wire takes some thinking to use.

*addon format meaning they have an info.txt file included. otherwise, you either put that in the main garrysmod directory (it should merge with folders like, sound, models, materials, lua), or add an info.txt, and put it in addons.

I’m having no problems with 7. If you keep on having troubles, give this a try!

RC1 is an upgrade to Vista, so no files would be lost.

It’s a very horrible idea to upgrade to 7 from Vista. It’s better to do a full reinstall.

As for your problems, make sure that the files are actually being copied over to the directory. Vista requires administrative access to copy files; UAC should prompt you before actually copying. If not, try these steps:

  1. Right-click your garrysmod folder --> properties
  2. Click the security tab. It may say you need admin access to see it; click the button so it will show.
  3. Click Edit…
  4. From there, click Add
  5. Type in your username for your PC in the box and click “Check Names”. It should underline it.
  6. Click OK/Apply for that window. Click the “Full Control” checkbox, then click Apply. It will go through and set permissions.

You’re done. Now you should be able to copy files to it without any issues.

I like how idiots who don’t know jack shit about vista jump on the hate bandwagon, that was SO last year

maybe the mods you’re installing are ones for Gmod9 or pre-OB update Gmod, alot of those still hang around garrysmod.org

or you’re just an idiot, probably both

System specs? Also, learn to spell.

I found out exactly what the problem is! (and I was right, it wasn’t Vista!)

This is a video explaining the issue

(I know the URL looks weird, but the site is fine)

Ive been playing the damn game for 2 years dl mods and using them with no problems until i got Vista. Vista is a piece of shit. Vista was what was causing all of my other mod problems but i just cant figure out how to fix it for gmod. I know how to use wiremod to ass hole. Dont fucking tell me that Vista isnt the problem cause it is smart ass little shit.

That’s because vista is NOT the problem, everyone else is fine with it, and you are the only one here with the problem