Gmod practically broken after newest update?

After the newest Gmod update, my Gmod completely broke and I don’t know how.

For starters, the menu doesn’t work. The buttons pop up but only Options, Multiplayer, and Tutorials work. If I try any others, I get errors on the console like these.


Unknown command: menu_startgame
Unknown command: menu_achievements
Unknown command: menu_extensions

I forced SP via console only to get encountered with this:

  • The Q menu doesn’t work.
  • I get a spam of lua errors if I try to open it.
  • I have that weird shit stuck on the top of my screen.

What is going on? Can someone help?

What a surprise, gmod broken after an update.

Thank you, your post was very helpful in trying to find a solution to my problem.

Systematically disable your addons a few at a time and see if that fixes it.
Defrag the cache.
Uninstall and Reinstall.

Similar problem, likely just wait for Garry to get his shit together and fix it?

Extract “garrysmod/lua/includes/modules/gm_sqlite.dll” from the “garrysmod content.gcf” using GCFScape to the same folder in your actual garrysmod folder. This just fixed it for me.

Thanks, that worked!

I have this problem as well, including a curious error I found in the console:

“GetAllManifestFiles: Unable to load maplist.txt”

I can’t actually open the single player button after the update that came out about 30 minutes ago, and if I do get into a game (via loading a game or playing online) I find the same symptoms as you

But I think that “weird shit stuck on the top of my screen” is actually something intentionally added in the update.

and _Undefiened, can you please elaborate on your potential solution? What is GCFScape? Where do I find “garrysmod content.gcf” or “garrysmod/lua/includes/modules/gm_sqlite.dll”?

Yes, I had already googled it, and found that it was a windows only program. The reason this update that fucked EVERYTHING up was released was because a portal/half life 2 update broke everything for Mac Users, me being one of them. I that update was supposed to fix our problems, but instead broke it for everyone else. What I really need to know, is if there is a way to perform that fix on a Mac, as Windows Only programs tend not to run on different operating systems.

My fault. Grr. I’ve sent another patch to Valve.

oh my god it’s garry newman