GMOD - Problem with DirectX

Hello !
I’m here because I have a big problem with DirectX.
I’m trying to run Garry’s Mod with DirectX8 or DirectX8.1 or 8.5 by writing +mat_dxlevel 80 in the launch options.
I launch the game, I close it then I erase +mat_dxlevel 80 from the launch options. Then I lauch Gmod again and I try to join a DarkRP server, but when the download starts my Gmod crashs.
I tried with DirectX 8, 8.1 and 8.5. I tried by writing -dxlevel 80 but it doesn’t work. (It doesn’t automatically save DirectX8 when I leave the game).
I want to play with DirectX 8 because, with DirectX9 I’m at 25fps in DarkRP and with DirectX8 I’m at 55fps.
My specs :
Intel Core i5-4200M
Nvidia GeForce 710M
4GB Ram
Windows 8.1
I tried to verify the cache of the game.
Sorry for my bad english.
If you have any solution please post it there.
Thank ya ! :smiley:

you really just have to keep the “+mat_dxlevel” launch parameter to stay on DirectX 8.
or are you disabling the parameter for other reasons?

I’ll try to keep +mat_dxlevel on my settings and I’ll answer u a bit later.

[editline]6th November 2015[/editline]

Okay, the game keeps crashing when I have “+mat_dxlevel 80” in my launch options.
Please find a solution :cry:

[editline]6th November 2015[/editline]

Ok, I found the problem, I have this bug when I connect to a server with the addon “DarkRP/DarkRP Derma”, i’ll try to found servers without this one.