Gmod problem.

I bought left 4 dead and then gmod the same night. Left 4 dead works perfectly but gmod doesnt work at all. When i click play, it has the loading screen with the guy holding the gun in a grassy place with birds around him. I will load everything but it gets to “Intalizing Serverside” then it crashes saying “hls.exe has stopped working”. I tried adding the -dslevel 70 and -dslevel 80 to the command line like people told me but it still doesnt work. Here is my computer specs:

Model: Compaq Presario CQ50 Notebook PC
Processor: Intel® Pentium® Dual CPU @ 2.00GHz 2.00 GHz
Memory (RAM) 3.00 GB
System Type: 32-bit OS

P.S I have a windows vista home premium edition

Please help.

run as admin

run what as admiin? steam? or…?

**I ran steam as admin but it did the same thing.

Video card specs?

Question. When you used the dx level thing did you type it “-dslevel 70 and -dslevel 80” as you did in your post or did you type it -dxlevel?

No, I think run Gmod as Admin. Steam just tells Gmod to play, not you, directly.

  1. how do i look up my video card specs?

  2. I meant -dxlevel 70 then i tried -dxlevel 80

  3. it wont let me run gmod as admin. when i right click it, it doesnt have the option.

There is a shortcut to run it in steam, then there is a desktop shortcut. You should try the one on the desktop.

when i try to create a shortcut to the desktop it says it cant make a shortcut because there is probably already one on there. but there isnt.