Gmod Purple and Black Textures

Hello,

Just got a New Pc and installed Gmod, Css, Hl2. When I go into Gmod singleplayer the grass on Gm_Construct & Gm_Flatgrass is purple and black… When I get a Hl2 gun out I can see the gun but not the hand holding the gun. I have Reinstalled Hl2 and Gmod and still haven’t been able to fix it? Is it something to do with steampipe? It was never like this on my old computer. I have tried verifying Gmod, CSS, Hl2. Nothing has worked… Can’t even see the Hl2 Magnum

http://speedy.sh/Nw7Gr/gm-flatgrass0000.jpg
http://speedy.sh/k4hR3/gm-flatgrass0001.jpg
http://speedy.sh/t9WSD/gm-flatgrass0002.jpg
http://speedy.sh/PAwCv/gm-flatgrass0003.jpg
http://speedy.sh/6K4Yn/gm-flatgrass0004.jpg

Start up CS:S and HL2. Then if it still doesn’t work, verify GMod.

I don’t think that will do it… Currently reinstalling CS:S

You don’t think so? How about you try?

[editline]1st July 2013[/editline]

The reason you have to start them up is because they have to convert to the new format.

I already did that… but I will try again when they have installed

Still experiencing this… please any help?

Are they mounted?

Yes I believe they are.

Nothing has worked so far… Just GMOD no other games do this just GMOD?! Help!

Have you tried validating all of your other source games?

I tried clearing out my whole steam… then reinstalled HL2 CSS and Gmod it FIXED! :smiley:

Put all other valve games in beta (opt in for steampipe beta) install and play one game. Then leave and try mounting

As I said in my last post… I fixed it.