Gmod ragdoll problem!

Someone please help!! I made a ragdoll in Blender to use in gmod. I created shape keys so I could face pose it (vta). The problem is the ragdoll is all messed up when I’m in gmod. Help!!
Here is a screenshot:


I get 2 error messages on the console saying:
‘‘Model missing : models/birdman.mdl’’ and ‘‘Requesting texture value from var ‘’$basetexture’’ which is not a texture value (material : pp/copy)

1 Like

You need a phys model.

1 Like

This is irrelevant to the problem, but it’s saying that in the VMT called “copy” something is wrong with $basetexture, show the vmt if you want help with that.

A lua file might be requesting this model? Can we see the full error message and also if there is any other file referencing the model?

Did the ragdoll work before you added a flex? If it did then that’s the problem, if not try to delete both shape keys and vertex groups, they are the only things that can modify a mesh, but I suspect something went wrong on either export or compile, import back the smd files into blender to check if it’s all well and good when exported from blender.

1 Like

Everything seems to be fine with the model when I open it on Blender, although the parts I weight painted on the model have less red in them. Maybe something is wrong on the compiler or the exporter on Blender, or even in the qc file, but how will I know exactly what it is? I need help from someone who is experient on this stuff, cause I’m a little lost.

1 Like

You do it by doing some basic troubleshooting to determine what is causing the problem, I already told you what to do and also asked a couple of questions to help you with that.

1 Like

I did what you told me to. Delete all vertex groups and shape keys. Didn’t really work. Now the model is this :

1 Like

Looks like it worked to me, now we know it’s either the rigging or the shape keys, if you kept the broken version of the model delete only the shape keys, as I suspect that’s the cause, basically complete the ragdoll except the shape keys.

At that point, the only remaining problem will be figuring out what you’re doing wrong with the flexes, who knows, maybe another person’s version of crowbar compiles it correctly, it’s not uncommon for it to break for someone but work for someone else.

What about the other problems? The ones in the console.

1 Like

Same thing ‘‘Model missing : models/birdman.mdl’’.

1 Like

Is the model actually there? Is there a Lua file referencing that model? Will it disappear if you place a model with that name in that path?

1 Like

Yes the model is in the exact path the lua file is referecing to. No it won’t dissapear. Also everytime I compiled the model with the vta file (flexes) written on the qc file, this happens :


I also don’t know if the skeleton of the model in Blender should be on Rest Position or Pose Position, I don’t know if that affects how the ragdoll acts in gmod.
I wish someone would make a tutorial already on how to make flex animation for ragdolls in Blender…

1 Like

The flexes are the problem, or more specifically the vta file, something is going wrong and I have a feeling I won’t be able to tell unless I interrogate you for 5 hours or you give me access to your computer, both which I am unwilling to do.

You have 2 choices:

  1. Don’t have flexes, they’re clearly the problem and if you can’t find the solution it’s not a big loss, especially since pretty much everything else is good

  2. Just nuke the whole thing and start fresh, get the latest versions of every program you’re using and redo the flexes correctly from the first step

The model thing in the console is most likely an error in how you wrote the lua file or something, it’s also likely you misspelled something somewhere, the texture problem you still haven’t addressed as I asked you to show the VMT and you still haven’t done that.

Given that everything is written and I’m not exactly on the edge of my seat waiting for your next reply I don’t see why you don’t respond to everything I tell you to do in my replies.

1 Like

I can’t send vmt file, the site doesn’t let me.

1 Like

Just copy and paste it or screenshot it

1 Like