Gmod refuses to load properly anymore.

Okay, so now everytime I boot up Gmod, I get to the menu, and everything just stops. At first, before certain games were converted to Steampipe, it would just think I have no addons and refuse to download new or updated shit. Now it’s even worse- now the whole damn menu doesn’t load properly. It’ll just load the background images, sometimes even the text, but nothing else. I’m fucking sick of this Steampipe shit not doing it’s proper job with reducing load times- it’s only screwed up my games, and this is a goddamn high-end machine. I’ve tried uninstalling, reinstalling, and even verifying/defragging the cache. NOTHING. FUCKING. WORKS.

Valve needs to get their shit together and fix their Steampipe games not properly working on certain machines; I just wanna play MVM and dick around in Gmod, is that so hard to ask for?!

Does awesomium render process crash on Garry’s Mod’s bootup?
I had similar problem. I have disabled steam community in-game on Garry’s Mod and it worked. Maybe it’s caused by unknown conflict between gameoverlayui.exe and awesomium_process.exe. Garry’s Mod Beta does have(as for moment of posting this) update 165, which works like charm even with in-game Steam Community access enabled.

…what?

Go to Garry’s Mod game properties and uncheck “enable access to steam community” then press OK. After that try to boot up game.

Didn’t work. Nothing ever fucking works anymore, I’m like “WTF, Valve?” This is a HIGH END MACHINE, Steampipe worked fine on the TF2 beta until the full conversion, and now Gmod, which I have TF2 mounted onto, doesn’t even fucking load anymore because of the switch. NOBODY has figured out what the fuck is really going on and it’s pissing me off.

  1. Validate your GMod and TF2 files by right clicking --> Properties --> Validate Integrity of Game Cache
  2. If that doesn’t work, follow these steps (if you have any HL2/Portal games). http://forum.facepunch.com/showthread.php?t=1271741
  3. If that once again does not work, delete your Garry’s Mod folder (or rename it garrysmod_old if there’s anything in there you would like to save) and reinstall.
  4. If it still does not work, delete your TF2 folder (or rename it) and reinstall.

Tell me how it goes.