GMod resolution - fooked.

Ok, here’s my awkward random story.

A few weeks ago, I wanted to get Mirror’s Edge props in GMod for some silly comic pose thing I was planning to make.

One problem: I didn’t own Mirror’s Edge!

After about a week of dancing for money, I got enough money to buy it.

I try running it and go “wow best game ever nerdgasm wow”. Then I remember that I bought it for GMod.

I try running GMod, but it crashed on “Initializing Serverside”… then it freezes for two hours.
But that’s not why I’m here. That was last week.

I spent 2 days searching around for fixes, and I found one.
Apparently I needed to set “dxlevel” to… 7, 9, I think. In the “startup options”.

Tried running it, but it still didn’t work.

1 week later, I randomly try to start it. Huzzah, it works.

But… Well…

The resolution is oddly odd, everything is cut off, the text is 75% smaller, and the toybox descriptions go off the screen.

If you want pictures I can upload them to tinypic.

But is there any way to switch it back to normal?

Also:

My screen resolution itself is smaller when I close GMod and it requires a restart to fix!

All of my evilicious plans are ruined with this deadly comeback. ;-;

Is there any way to “revert” the dxlevel?

If this actually has anything to do with the resolution itself, that is.

This is very urgent for me.

right click GMod in steam, do the startup options “-dxlevel 9 -windowed -w 1024 -h 768”

[editline]10th November 2010[/editline]

tell me if that works

Nowhere near working.

It opened in a silly window.

I’ll tell you what it originally looked like:

“Widescreen” bars on the left and right

Fullscreen

…that’s about it.

EDIT:

A small line on the bottom is cut off by my taskbar and the ‘FULLSCREEN’ in the top right is grayed out.

this is bad.

Try -autoconfig ? It should fix it. Maybe.

stop

fucking

randomly

spacing

anyways

Get rid of DX7. You don’t need 7.

:doh: times two.

Not only did you just set his DX level to 0.9, you used the command in the first place. It resets all your settings every single time the game launches.

One’s DX level is a two digit number. -mat_dxlevel 9 = -mat_dxlevel 09

A better way to change it is via registry editing. Here’s how:

Start > Run…

Type in “regedit” and hit OK. Registry editor should open.

Navigate to HKEY_CURRENT_USER\Software\Valve\Source\garrysmod\Settings

On your right, you should see what appear to be console commands. Find “DXlevel_V1” and double-click on it. A small window should open. Click set the base to “Decimal” and type in your two-digit DX level. In this case, 95 or 98.

lol

That really should work, I hope.

Will it start right after I edit it, or do I need a restart?

EDIT:

Well, shit.

That didn’t change ANYTHING at all.

Remember that the problem is my screen resolution; The size of the window itself. At the size it is now, the top and bottom are cut off by the screen, and the text is severely shrunken.

Originally, it had two bars left/right, nothing was blocking it, text size was readable.

What is your monitor resolution and your GMod resolution? make GMod one smaller than your monitors.

Source =/= Unreal.