Gmod server and +exec, not working no matter what

Hello, long story short, I have a VPS with a few servers on it. They’re all working fine and whatnot, but today I decided to add a second Garry’s Mod server. In my startup script file, no matter what position the +exec is it, it just doesn’t get recognized/passed. I’ve been on several forum posts/guides attempting to address this issue already but none have brought any solution. My other Gmod server runs Sandbox constantly, this one in particular is to be used for either Deathrun, SledBuild, or etc. gamemodes.

Startup script for the faulty server:



#!/bin/sh
cd ~/core/gmod
./srcds_run -game garrysmod -authkey XXXXXXXXXXX -ip x.x.x.x -port 27018 +exec sled.cfg +maxplayers 10 +gamemode sledbuild +map slb_snowsled_v3 +sv_loadingurl "loadingurlhere" +host_workshop_collection 235133655


The authkey, ip, and loadingurl are of course valid, but just not shown here.

This startup code is pretty much a duplicate of an existing (working) script.

I had deleted the server.cfg, and when I did that, the server would load the server.cfg from my Team Fortress 2 server’s install… Not sure why, but having mounted this game’s content seems like a reason for the server to explore these files.
I also figured permission may have been an issue, but after chmod’ing the .cfg and .sh to 777, that still didn’t fix anything. There are no errors or anything interesting specified in console and everything starts up like it normally should, but not using the .cfg file specified by +exec.

Nonetheless this is pretty frustrating considering it isn’t working as it’s supposed to, and I truly appreciate any assistance on this.

Put exec sled.cfg in your autoexec.cfg, not in your startup script.

Thanks for the reply. I’ll certainly attempt this. However, both servers are installed in the same directory and must remain that way (disk space), so wouldn’t this make the sandbox server load the sled.cfg also?

I don’t think you need to put the “ip” parameter

I guess as a workaround, you could try making a lua file that detects the gamemode, and if it’s sled, it will set the convars to what they are in the sled.cfg.

You’re probably right. That’s how it was before I moved to the VPS, it needed to be specified to show in the master list for whatever reason.

Seems like a pretty good approach. I’ll attempt it and see how it goes. Thanks for the suggestion.

In some cases, for RCON to work the IP param has to be set. I used to get “Could not connect to RCON server on 27015” when I didn’t have the IP param set.