G'Mod server errors, held by srcds

Hi folks, I’m from Taiwan
I’m currently trying to held a G’Mod server to play prophunt w/ my friends, with srcds

I’ve watch Jack’s tutorial video(which is actually for darkrp)
I succeed in extract the gamemode(maybe), and 1 map to my G’Mod server

But this problem occurred

I don’t actually know why because I’m really new to this, just following video and stuff

Now I can go in to my own server, but I can’t change team or do any prophunt thing

Can only walk around and moving stuff, can’t see two team from pressing F2

Can anyone help? Really want to do this for my friends.

Do you have fretta gamemode installed? You’ll need it for prop hunt.

Oh I didn’t know…kk I will go do it naw, but how do I correctly install a gamemode to G’Mod server?

Didn’t know how I installed prop_hunt too xD
Just use GMAD to extract prophunt from my steamlibrary

[editline]5th May 2014[/editline]

This happen after I downloaded some zip file called “fretta”, and put it into garrysmod/gamemodes

Really have no idea what I’m doing T.T

You are using an outdated Prop Hunt and Fretta. Use an updated Prop Hunt; try the workshop if you can’t find one.

It’s outdated? But I extract that one from my steamlibrary…which I think it’s from workshop
It’s in the highest rate gamemode, the second one with some Korean character, not the hide and seek one
Because you can’t move props by pressing E in that mode

And I can only find downloadable fretta here http://www.garrysmod.org/downloads/?tag=fretta

Are these what I need?

No. Use this: http://steamcommunity.com/sharedfiles/filedetails/?id=135509255

Oh it’s the hide and seek one, this one makes me unable to pick things up
either as a props or a hunter, which is a bit inconvenience.

BUT

BUT

EXCEPT THAT

The server is working!!! There are two teams and spectator!!!

Although I want to make it possible to pick things up but, this is already GREAT

A BIG THANK YOU TO YOU SIR! : )

[editline]5th May 2014[/editline]

But now my friends can’t connect, it says server not responding ;(

Dunno why…is there any possible causes?

That’s an issue with either your firewall or ports not being forwarded.

Can it be fixed by me simply turn off my firewall when I’m helding the server?

You can try, but make sure it’s a firewall issue first.

I tried, it worked XD! Really helped a lot mate

But I still wanted to know how do I forward my port?
I’ve watch a video tutorial

but his D-LINK site is totally different from mine
It makes me kinda confuse.

I went to my router page and find NAT->port triggering
And I add a new port, combined from several tutorial, But it seems different

[editline]5th May 2014[/editline]

Anyway, it kinda works now XD
Just have to turned off my firewall when I’m opening the server

It’s quite good, because before this I have to BE in the game when I open a server for my friends

Port triggering is different from port forwarding.

Can’t find port forwarding at my router page tho :confused:

It’s not always called port forwarding in the router, just check anything to do with ports

Only found port triggering xD I add a port though, didn’t know if it’s right