Gmod Server Help

Gmod DarkRP will not load from the gamemodes folder, I have used the Git from the git link and the server does not see the gamemode, I tried doing “gamemode darkrp” in console and it still did not work. I also tried using the Ulx Menu to try to change it but that wont work either. Its like the gamemode isn’t there but it is.

On a side note, The server isn’t even seen on the server list. Its not locally hosted, I have a Vps with Ubuntu 12.04.

Thanks, G2

Any errors from using ‘gamemode darkrp’ in console?
Is the gamemode folder named ‘darkrp’ and not ‘darkrp-master’?

Well normally you put ‘gamemode darkrp’ in autoexec.cfg. Without the quotes though.

Put +gamemode darkrp in your startup.bat as opposed to your autoexec. Also, make sure the gamemode folder name is darkrp, all lowercase.

That does not work, I have tried all those the folder name is “DarkRP” exactly.

Did you try making the name all lowercase instead of DarkRP?

I have, Yes

What’s the exact error on startup? Also, post the structure inside the DarkRP folder.

Can you contact me on steam?: water17777 (Shows up as [R|T]G2-=RaidTekk=-)

Its a guy with a thuggish sort of hat ;3

I don’t help over Steam. Just post here.

The main error I want solved is the no server list thing, As I run a server host and they don’t work well. And the DarkRP says “darkrp gamemode could not be found”
I have did my chmod and chown. That’s not the reason. It is in the right place.

Can you please post the file structure of your DarkRP folder?

What does that mean?

[editline]11th March 2014[/editline]

The files inside?

Yes.

root@:/home///1/garrysmod/gamemodes# cd DarkRP
root@:/home//
/1/garrysmod/gamemodes/DarkRP# dir
CONTRIBUTING.md README.md entities logo.png
DON’T\ TOUCH\ ANY\ OF\ THESE\ FILES.txt content gamemode
HELP darkrp.txt icon24.png

Code_gs asked this: Did you try making the name all lowercase instead of DarkRP?
You answered: I have, Yes

But no, you haven’t. It’s still DarkRP (root@:/home//****/1/garrysmod/gamemodes/DarkRP)

Run this when you’re inside the gamemodes folder (cd to it):


mv DarkRP darkrp

Still does not work **Couldn’t change active gamemode - ‘darkrp’ not found

**

I have a feeling you’re being ignorant and not listening to what we say. Now again, run the ls command when you’re inside the gamemodes folder and tell us the output.

Well, I didn’t see you say that! I ran two commands just to make sure, I ran ls and ls -l

root@RaidTekk:/home/ogp_agent/OGP_User_Files/1/garrysmod/gamemodes/darkrp# ls
CONTRIBUTING.md HELP content entities icon24.png
DON’T TOUCH ANY OF THESE FILES.txt README.md darkrp.txt gamemode logo.png

root@RaidTekk:/home/ogp_agent/OGP_User_Files/1/garrysmod/gamemodes/darkrp# ls -ltotal 56
-rwxrwxrwx 1 ogp_agent ogp_agent 4207 Mar 6 14:57 CONTRIBUTING.md
-rwxrwxrwx 1 ogp_agent ogp_agent 2101 Mar 6 14:57 DON’T TOUCH ANY OF THESE FILES.txt
drwxrwxrwx 2 ogp_agent ogp_agent 4096 Mar 6 14:57 HELP
-rwxrwxrwx 1 ogp_agent ogp_agent 417 Mar 6 14:57 README.md
drwxrwxrwx 6 ogp_agent ogp_agent 4096 Mar 6 14:57 content
-rwxrwxrwx 1 ogp_agent ogp_agent 373 Mar 6 14:57 darkrp.txt
drwxrwxrwx 4 ogp_agent ogp_agent 4096 Mar 6 14:57 entities
drwxrwxrwx 5 ogp_agent ogp_agent 4096 Mar 6 14:57 gamemode
-rwxrwxrwx 1 ogp_agent ogp_agent 642 Mar 6 14:57 icon24.png
-rwxrwxrwx 1 ogp_agent ogp_agent 14971 Mar 6 14:57 logo.png
root@RaidTekk:/home/ogp_agent/OGP_User_Files/1/garrysmod/gamemodes/darkrp#

Btw, The server is supposed to run under my user “ogp_agent”

Anyone know?