Gmod Server Player Models Error

So i have a gmod server but the player models are errors to everyone else. I have fastdl on and everything is connected right atleast on the downloading the addons part. They can see the npc’s when they spawn them in but not the player models. for example i have the ponies addon and the path is “models/player/ponies/rainbowdash_player.mdl” but its an error to everyone else.
Do i have to change the path, or what? D:

Post your server.cfg and resource.AddFile/AddWorkshop Lua file.

server.cfg =

hostname DickHeadRP|GangWars!|Grand Opening!|25+ Jobs!|FastDL|
sbox_maxballoons 100
sbox_maxdynamite 75
sbox_maxemitters 100
sbox_maxlamps 50
sbox_maxnpcs 50
sbox_maxragdolls 50
sbox_maxthrusters 200
sbox_maxwheels 200
sbox_maxbuttons 200
sbox_maxeffects 200
sbox_maxhoverballs 200
sbox_maxlights 50
sbox_maxprops 1000
sbox_maxsents 1024
sbox_maxvehicles 1
sbox_maxhoverboards 1
sbox_maxkeypads 100
sbox_noclip 0
sbox_godmode 0
sbox_weapons 0
sbox_maxtextscreens 20
sv_loadingurl “http://dickheadrp.weebly.com/loading.html

workshop.lua=

resource.AddWorkshop(“109643223”)
resource.AddWorkshop(“163806212”)
resource.AddWorkshop(“158061274”)
resource.AddWorkshop(“434410061”)
resource.AddWorkshop(“104607712”)
resource.AddWorkshop(“105115318”)
resource.AddWorkshop(“104558227”)
resource.AddWorkshop(“106958912”)
resource.AddWorkshop(“171093607”)
resource.AddWorkshop(“110871780”)
resource.AddWorkshop(“150455514”)
resource.AddWorkshop(“476997621”)
resource.AddWorkshop(“108424005”)
resource.AddWorkshop(“128089118”)
resource.AddWorkshop(“128091208”)
resource.AddWorkshop(“128093075”)
resource.AddWorkshop(“144982052”)
resource.AddWorkshop(“105841291”)
resource.AddWorkshop(“104486597”)
resource.AddWorkshop(“125490679”)
resource.AddWorkshop(“126569806”)
resource.AddWorkshop(“110286060”)
resource.AddWorkshop(“207948202”)
resource.AddWorkshop(“109586003”)
resource.AddWorkshop(“131586620”)
resource.AddWorkshop(“104479831”)
resource.AddWorkshop(“114578864”)
resource.AddWorkshop(“317039941”)
resource.AddWorkshop(“175345838”)
resource.AddWorkshop(“131710286”)
resource.AddWorkshop(“109464282”)
resource.AddWorkshop(“362803586”)
resource.AddWorkshop(“111603898”)
resource.AddWorkshop(“454787966”)
resource.AddWorkshop(“479255957”)
resource.AddWorkshop(“391383735”)
resource.AddWorkshop(“229683363”)
resource.AddWorkshop(“109463165”)
resource.AddWorkshop(“249325395”)
resource.AddWorkshop(“104771157”)
resource.AddWorkshop(“171925253”)
resource.AddWorkshop(“174117071”)
resource.AddWorkshop(“172303156”)
resource.AddWorkshop(“107382750”)
resource.AddWorkshop(“310799693”)
resource.AddWorkshop(“117935890”)
resource.AddWorkshop(“248643568”)
resource.AddWorkshop(“107155115”)
resource.AddWorkshop(“104548572”)
resource.AddWorkshop(“104479467”)
resource.AddWorkshop(“160134938”)
resource.AddWorkshop(“232539187”)
resource.AddWorkshop(“241187700”)
resource.AddWorkshop(“107087351”)
resource.AddWorkshop(“391383735”)
resource.AddWorkshop(“157748952”)
resource.AddWorkshop(“453667254”)
resource.AddWorkshop(“158700168”)

That’s WorkshopDL, not FastDL. Also, you need to have a +host_workshop_collection flag for models so the server had them. Lastly, where is your workshop.lua file located?

my workshop.lua is located C:/gmod/garrysmod/lua/autorun/server

can you tell me how to hookup fastdl cuz i thought that was fastdl.

I already hooked up the workshop collection thing in my start.bat so i guess the workshop downloads are working. They do end up downlaoding the addons just they cant seem to see the player models. is it because that i made it models/player/Ponies instead of models/players/(the model)? because i put it in a custom folder?
im sorry for all the questions im new to this xd

You can get the model path using GMad.

so what i do is take the exact path from extracting with gmad and it should work?

Please stop advising this method.

It’s easier to go to Sandbox and copy model paths through spawnmenu then manually constructing model paths for each extracted file.

bump

Yes. models/whatever/modelname.mdl

[editline]18th July 2015[/editline]

okay

I’ll try that and i’ll post if it works so stay tuned :stuck_out_tongue:

yea it worked! thanks guys :smiley: all i had to do was copy it from the clipboard from the spawn list or jst find the directory from gmad. making your own custom paths dont work