gmod server segmentation error (centos)

So i have been having an issue with transferring my gmod servers from detain to CentOS for the last day and i keep running into the same error each time which is: http://pastebin.com/vaWPMqYn

I’ve had no issues with Debian at all but since i have changed over to CentOS it just wouldn’t start the server. I have been looking online all night for any solution and the only one i can find is related to the Linux binaries but these post are old and may not be relevant now as i can’t even download them binaries to test it.

Sorry if i have not included enough information i am just very tired and need to find a fix as soon as possible. I would most appreciate it if someone can help me find the cause and some of you may already be aware of this issue as it is common for ubuntu and CentOs users