Gmod Server Won't Download Workshop Files

Hi everyone my gmod server won’t download any of the addons i have setup in my workshop.lua it downloads everything i have setup in fastdl completely fine but everytime i join my server it just skips all the workshop addons with the error Addon download failed err2. I’ve tried setting up the host workshop collection but that didn’t work and i’ve tried using the .gma files and reinstalling and that wouldn’t work either. I have no clue on how to fix this as google has next to no help with this error code.

link to my workshop.lua https://pastebin.com/aimuTiyG

The problem is with your client specifically and not the server. The game fails to read the downloaded file in downloads/server/XXXXXXX.compressed

Would you have any idea on how to fix it? i deleted the 2 files in the folder but they just came back when i rejoined.

Must be something wrong with your PC.

Where exactly is your game installed? What’s the full path to the downloads/ folder?

Garry’s mod is installed at C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\garrysmod\downloads

And The Server Is Just On The Root Of C:

[editline]8th August 2017[/editline]

To Add On To My Other Reply This Is Where The Main Server Folder Is Located.
C:\Gmod Server\steamapps\common\GarrysModDS\garrysmod