Gmod Spawn Menu, Main Menu, and Toolgun problems

Hey, I’ve been using Gmod for about 5-6 months, and I’ve been able to keep it clean and not have that many problems, but this is the most annoying and unsolvable problem I’ve ever encountered. Lately, for an unknown reason, my Gmod Main Menu screen turned into the Gmod loading screen, where I can’t play singleplayer unless I load a SAV. file, and all the props on the map are gone. Even worse, when I try to bring up the Q-Menu, a yellow colored error appears stating that the sandbox gamemode is having gui error. Also, when I pull out the toolgun, theres an ammo count (which shouldn’t exist) and uses an error model (both world and viewmodels). Yes, I’ve tried to reinstall Gmod, delete the gcf. file, and it still hasn’t worked. Anything else I should try to fix this?

Have you tried cleaning gmod? http://wiki.garrysmod.com/?title=Cleaning_GMod

I did that, and theres major improvements.
-Theres a toolgun model
-The Loading and Main Menus are working
-I can use the Q-menu

The only problems are that the remover “i mean the toolgun’s remover” is in the “New Category Section” and doesn’t work. Also, the Background to the Q-menu is missing, but I can deal with that,