Gmod srcds game mounting problem

Hello.

I’m trying to mount different games for a gmod srcds. Now I am able to mount props from games, such as CSS, DODS, TF2, etc. However with episode 1 and episode 2, I can’t get the npc’s and the jalopy vehicle from their respective games to mount on there. The jalopy, hunter, magnusson, zombine. Those npcs are obviously from their respective episodic hl2 games. So how come the props from those games will mount but not the npcs and vehicles? Anyone know what I’m doing wrong? I tried following these 2 guides to the best of my ability: http://wiki.garrysmod.com/page/Mounting_Content_on_a_DS & http://wiki.garrysmod.com/page/Retrieving_content_to_be_mounted_on_a_Dedicated_Server

If you need anymore information about the problem please let me know. Thanks in advanced for any help or suggestions.

Send me your mount.cfg



//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

"mountcfg"
{
	// "cstrike"	"C:\steamcmd\steamapps\common\Counter-Strike Source Dedicated Server\cstrike"
	// "tf"			"C:\mytf2server	f"

	"cstrike"	"C:\Program Files (x86)\steam\steamapps\common\Counter-Strike Source\cstrike"
	"tf"		"C:\Program Files (x86)\steam\steamapps\common\Team Fortress 2	f"
	"episodic"	"C:\Program Files (x86)\steam\steamapps\common\Half-Life 2\episodic"
	"ep2"		"C:\hl2ep2\ep2"
	"lostcoast"	"C:\Program Files (x86)\steam\steamapps\common\Half-Life 2\lostcoast"
	"portal"	"C:\Program Files (x86)\steam\steamapps\common\Portal\portal"
	"dods"	"C:\Program Files (x86)\steam\steamapps\common\Day of Defeat Source\dod"
	"l4d"		"C:\Program Files (x86)\steam\steamapps\common\left 4 dead\left4dead"
	"l4d2"		"C:\Program Files (x86)\steam\steamapps\common\left 4 dead 2\left4dead2"
	"portal2"	"C:\Program Files (x86)\steam\steamapps\common\Portal 2\portal2"
}


The “ep2” line I used Steam CMD and used the app_update command 420 to download episode 2 files. Originally I tried going to the common folder and mounting it there. The same problem happens either way. The props work but not the episodic npcs or the jalopy from ep2. Also those other games I have there the props spawn perfectly no problem. Something tells me I’m doing something wrong here…

Does anyone know what to do here I’m still stuck on this problem… :suicide:

Your mount.cfg looks good; just make sure your paths are absolutely correct or try reinstalling the content.

Yeah, i’m getting this problem too


//
// Use this file to mount additional paths to the filesystem
// DO NOT add a slash to the end of the filename
//

"mountcfg"
{
	"hl2"	"C:\Users\Jamie\Desktop\Steam CMD - Server\steamapps\common\Half-Life 2\hl2"
	"episodic"	"C:\Users\Jamie\Desktop\Steam CMD - Server\steamapps\common\Half-Life 2\episodic"
	"ep2"	"C:\Users\Jamie\Desktop\Steam CMD - Server\steamapps\common\Half-Life 2\ep2"
	"lostcoast"	"C:\Users\Jamie\Desktop\Steam CMD - Server\steamapps\common\Half-Life 2\lostcoast"
}


My mount cfg, all props spawn fine, but NPCs / Jalopy does not
Anyone know a fix to this?

What gamemode are you using? Also, the jalopy has been broken for a while.

Sandbox

http://steamcommunity.com/sharedfiles/filedetails/?id=182886789 <All the addons, plus Falco’s prop protection and ULX/Ulib SVNs

I have the same problem with ep1\ep2 content as well.
Props and maps load fine on a dedicated server, but Jalopy and NPC (but their ragdolls will) will not work.

Yet they work fine in single player or a listen server.

Errr You need to login to download Ep content, or you can drag and drop the VDF’s from your game into the server dir

They are downloaded, didnt you read all the posts? it lists directories of the installed content, and we have said that everything but NPCs / Jalopy works.

Not sure about the NPCs, but as I said earlier, you cannot spawn the Jalopy anymore. It’s broken.