Gmod Starts up a map background

I`ve managed to fix this problem by simply umounting nightmare house 2, but still, anyone got any ideas as why that particular game being mounted with GM_MOUNT 2 caused this ‘problem’?

Out of nowhere, today, 09/20/2010, my gmod started to create a map as the background, I played it yesterday and nothing happened, just the first time I open it, bang, it loads a map as its background, just like other source games (hl2, ep1 and ep2), heres a condump:



Mounting hl2.. OK
Mounting cstrike.. OK
Mounting dod.. No permission
Mounting ep2.. OK
Mounting tf.. OK
Mounting episodic.. OK
Mounting hl2mp.. OK
Mounting portal.. OK
Mounting lostcoast.. OK
Mounting hl1.. No permission
Mounting hl1mp.. SteamMountDepot: Error SteamMountFilesystem 360 - (dependency 4 (281))
	 SteamMountFilesystem(3764,281,0xfbafd28=,0xfbafc18) failed with error 5: No Steam Content Servers are available
OK
Mounting zeno_clash.. No permission
Garry's Mod server.dll Build #099 [Sep  8 2010 17:27:21]
maxplayers set to 128
Unknown command "sv_allow_wait_command"
Steam config directory: d:\steam\steamapps\filipegroh\garrysmod\platform\config
Parent cvar in server.dll not allowed (sv_scriptenforcer_initialkick)
Garry's Mod client.dll Build #099 [Sep  8 2010 17:27:20]
Mounting game 'insurgency'.. OK
Mounting game 'left4dead'.. OK
Mounting game 'zps'.. OK
Mounting sourcemod 'fas'.. OK
Mounting sourcemod 'NH2'.. OK
maxplayers set to 1
Unknown command "cl_thirdperson"
Unknown command "hud_showemptyweaponslots"
Unknown command "sv_backspeed"
GetAllManifestFiles:  Unable to load maplist.txt
Lua initialized (Lua 5.1)
Registering gamemode 'sandbox' derived from 'base'
ScriptEnforce is disabled
Executing listen server config file
Couldn't find scene 'scenes/npc/female01/question21.vcd'
Couldn't find scene 'scenes/npc/female01/question31.vcd'
Couldn't find scene 'scenes/npc/female01/answer35.vcd'
Couldn't find scene 'scenes/npc/female01/gordead_ques03a.vcd'
Couldn't find scene 'scenes/npc/female01/gordead_ques03b.vcd'
Couldn't find scene 'scenes/npc/female01/nice.vcd'
Couldn't find scene 'scenes/npc/male01/nice01.vcd'
Couldn't find scene 'scenes/npc/male01/nice02.vcd'
Couldn't find scene 'scenes/npc/female01/oneforme.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_run.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_ohshit.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_thisisbad.vcd'
Couldn't find scene 'scenes/npc/Barney/ba_headcrabs.vcd'
Error: Material "models/w_pillbottle" : proxy "HighlightWeapon" not found!
Error: Material "models/w_medkit" : proxy "HighlightWeapon" not found!
Error: Material "models/jacket" : proxy "HighlightWeapon" not found!
Unknown command "ins_forceautoassign"
Unknown command "ins_forcesquadopen"
Unknown command "ins_gamecount"
Unknown command "ins_roundtimer"
Warning: using WorldTwoTextureBlend on a non-displacement surface.
Support for this will go away soon.
   - Material       : nature/red_grass
   - Surface center : -904 -1438 0
Warning: WorldTwoTextureBlend found on a non-displacement surface (material: nature/red_grass). This wastes perf for no benefit.
InitFastCopy: only 51% fast props. Bug?
Lua initialized (Lua 5.1)
Registering gamemode 'sandbox' derived from 'base'
ERROR: Trying to derive entity npc_stalkerdog from non existant entity monster_base!
Sending 267 'User Info' ConVars to server (cl_spewuserinfoconvars to see)
Redownloading all lightmaps

The only thing I did before running Gmod for the first time today was replacing standard HL2 healthkits and ammunitions with the ones from Zombie Panic Source, altough I don`t really think thats what caused the problem

Isn’t this good? I want my backround to load up a map.
Also I don’t see anything wrong