Gmod startup error?

I was playing for a while today, and I switched to gm_excess water. I tried spawning a Predator missile from the MW2 killstreaks, and it froze. I had Task Manager open, so I ended the Gmod task. (Not the process)
I went into the garrysmod folder and into the addons so I could delete some old crap that I never use any more. I remember deleting a folder called “zeno_clash” that only had a spawnlist, because I don’t have Zeno Clash and when I tried restarting Gmod, I got an error saying something along the lines of “Startup error: could not connect master pipeline” or something. (I don’t know exactly what it is right now, because I turned off my computer and I’m using another one to post this.)
I restored the zeno_clash folder and tried again, but it didn’t work.
I know it’s vague and/or limited information, but does anyone know what this might be?

Also, Gmod has been acting strangely for me today, like changing the menus, not bringing up the weapons and vehicles spawnlists, no shadows, etc.

Restart Steam