Gmod Vehicle Compiling

Would someone be able to inform me what the best program would be best to use to compile a drivable vehicle? When I use GUIstudioMDL, the model itself disappears ingame.

Use notepad to make the qc, use studiomdl.exe to compile it, its that simple, also check if u didnt forgot to add the wheel attachments, that makes the model dissapear.

I haven’t used studiomdl.exe before, is there any specific way to use it?

drag and drop the QC on top of it - just start the SDK beforehand.

Alternatively if you compile a lot of stuff, you can set up a right click compile option for QC files in the registry.

Just Create a text file, rename the extencion to .BAT and plaste this text inside:



"C:\Steam\steamapps\YOURACCONTNAME\SourceSDK\bin\orangebox\bin\studiomdl.exe" -game "C:\Steam\SteamApps\YOURACCONTNAME\GarrysMod\garrysmod" %1


Then just drag your QC to that bat and it will compile it with the OrangeBox Studio MDL to the game Garrysmod. be sure that Steam is running and that the path folder your model will go exists, also that in the garrysmod folder the gameinfo.txt exists.

I keeping getting a red line at the end of running it, but my bat file closes before i can see what it is.

Add:



"C:\Steam\steamapps\YOURACCONTNAME\SourceSDK\bin\orangebox\bin\studiomdl.exe" -game "C:\Steam\SteamApps\YOURACCONTNAME\GarrysMod\garrysmod" %1
**pause**


Pause will keept the window open, reply back the error you got.

" Error opening D:\D:\Steam\SteamApps\alexander_james\GarrysMod\garrysmod\models/car/car.mdl <check for write enable>

Check that the folder where your compiled model will go exists, also plaste here the qc line of the path and name of the model to check if its right, rembember that the path needs to be relative to the models folder path not all the Window disc partition path.

I managed to compile the model but when i tried to view it using HLMV it didnt appear.

Check if your HLMV is loading other custom models, check also ingame with the path explorer in the spawmer menu to find it.

I tried in the HLMV and ingame but the model is still invisible. If i change the sequence in the HLMV it works but not at idle.

mmm… maybe your idle anim is screwed, test set the reference model as the source file of the idle anim.

The model spawns but the look of the model spawns to the left of it. That is the idle animation isn’t it? Could you tell me how to make the idle animation then?

Just use the same smd you use for the reference as the anim, for example if your ref file is called car_ref.smd it would be like:




$sequence "idle" "car_ref.smd" fps 30 ACT_IDLE 1



That should work.

Also that error could be related with the PHY mesh having a different skeleton to the one that the main mesh has.

I just decomplied the Lambo to see if when i compile it to see if that works but some reason that doesn’t work either?

Maybe your Source SDK installation is fucked? Either that or decompiling screwed the model up, somehow.

Even if i got the latest version from studiodecomplier, the model is missing certain parts

Decompile and Recompile a model its not that simple, you need to line up a lot of stuff and redo what is missing.