Gmod: Won't Update and can't Join Servers Please help

Whenever I Launch Gmod and Join a server it says “The Server you are trying to connect to is running a newer version of the game.” Gmod has not auto-Updated, and no one Knows how to help me. I already turned the settings to “high priority” on properties, but it didn’t help. Can someone please help me ASAP! I am an Administrator on a server and they need me, BUT I CANT CONNECT!

Try verifying game cache integrity.

Thank you so much! I literally had to ask every single person I knew and they told me to go into the game files and stuff. But the answer was as simple as that! I LOVE YOU!