Gmod13 Linux Server Segment Fault

Hello, A few days ago i had some what of the same error, but I fixed it by redownloading the bin files. But today after a minor srcds linux update, I am starting to get this error:


Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "ûv"
Setting breakpad minidump AppID = 4000
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/home/source/.steam/sdk32/steamclient.so
with error:
/home/source/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
PreMinidumpCallback: updating dump comment
Segmentation fault
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Mon Feb 18 20:46:04 EST 2013: Server restart in 10 seconds


I tried to redownload the bin files and it isnt working

same problem here, no fix to be found

Redownload your binary folders

That helped :slight_smile:

By Binary folder do you mean the ‘bin’ folders? Because I just deleted the 3 bin folders (In the root of the SRCDS folder, in orangebox and in the garrysmod folder) and it still did not fix it

I had to reinstall my whole server this last update for it to not crash on startup, it was something in the garrysmod folder I never did figure out what it was… See if you can get a fresh install to start.

I removed all the Garry’s mod files and redownloaded them and it is still not working :confused:

Delete the bin folder in orangebox/
?

Ok, Im going to try that again. So I deleted the bin file in orangebox… But now when I run the updater, it says that no new files need to be downloaded?

EDIT: Weird, now it works! Thanks again for the help. They should really fix this.

ok I got this issue after i fixed the .so issue “[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed” ? any idea

Ok so it starts up and everything is fine(Players can join, addons work, etc…) but when I type “quit” to stop the server, it gives me another segment fault? Does this happen to anybody else?

Mine have always segfaulted when I “quit” it’s done that for as long as I can remember

I deleted the bin folders and yet the server still doesn’t seem to be working. (I’m getting the same errors as the OP)

Same for me and I have tried everything. It is like I get it working then I change the map and then ulx breaks. Then if I try and fix that I end up back at square one. I have tried Deleting the bin folders , updating steam, verifying the game files, updating Linux Ubuntu, re downloading libraries, and using bin files that worked originally. None of these things have helped me and I can not install a fresh copy of srcds because it gets stuck at 5 depot(s) when launching the server. I have it running for 5 hours i hopes it was just taking a while , but nothing changed. I want to make a whole new post on this because some errors of mine are not the same as this, but I feel all I would get is a redirect to this thread. I have emailed steam and sent the the dump files in hopes they can help me.


Game_srv.so loaded for "�v��"

Weird. I solved the issue by removing orangebox/bin/ and orangebox/garrysmod/bin/

That didn’t work for me, this issue still needs resolving or if any other advice can be given it’d be appreciated.