GMPublish broken?

So I’m trying to publish my first Workshop addon, and this happens:

http://puu.sh/7w6t1.png

First of all, the image is 512x512, I even re-exported it multiple times (and then changed the filename and added quotes just to be sure).
Secondly, notice how the Steam storage quota is going down, yet I don’t see my addon (or the other failed ones) on my Workshop page. It’s been a good 30 minutes since I tried this, and it still hasn’t shown up.

So, I have 4 invisible addons apparently without images with no way to remove them and a broken GMPublish. What the fuck is going on?

[editline]penbis sipsuster[/editline]

Of course no one posts. I really wanted to finish this quickly.

Open the image in Paint.NET ( Or paint? ) and do “save as” for the image.

I figured it was a problem with the headers.
I would have tried that yesterday but I died from exhaustion.

So what do I do about the extra files? Are they just going to sit there?

Yes. Not that you’ll need those 20MB again. You have 1000 left.

Wow that’s really stupid.

Thanks anyway.