GMPublish - Can't Update

Really quick, I have created an addon, and uploaded it. I then needed to update it, but when I tried, gmpublish said "Can’t edit workshop id 0 <are you the author?>
I am, I am logged in, my steam is on but it can’t recognize that I want to update the addon. Help would be much appreciated!
:dance::dance::dance::dance::dance::dance::dance::dance::dance::dance::dance::dance::dance:


(User was banned for this post ("wrong section" - postal))

More info & in the right forum section would help.

What is the command line you’re trying.

gmpublish update -addon “C:\Program Files (x86)\Steam\SteamApps\common\GarrysMod\garrysmod\addons\Megaphyscannon By ErrolLiamP\phygunbyerrol.gma” -changes “Fixed not showing up in Half-Life 2 Weapons Tab”
That is the command line I am using for gmpublish
I simply deleted the old gma file, created a new one and tried to upload it. I got the code from garry’s forum and I put my stuff into it, but that error appeared. What other details would you need?

You need to provide the ID of the addon you’re updating. For example:



gmpublish update -id 123456789 -addon "C:\Program Files (x86)\Steam\SteamApps\common\GarrysMod\garrysmod\a ddons\Megaphyscannon By ErrolLiamP\phygunbyerrol.gma" -changes "Fixed not showing up in Half-Life 2 Weapons Tab"


How would I find the id? Would I goto my addons folder and get the numbers that show after the gma’s name? Thanks alot for replying!!!