GMpublish/workshop tools needs to be updated badly

Why on earth are these archaic tools still practically unchanged from their first incarnation?

I bring this up because of issues I’m having with my latest map, which needed FIVE CONTENT PACKS. My file relies on five other files, just to work. As I’m uploading alternate maps for other gamemodes, with updates and additions to the content files, this is going to be a massive headache to update. Ideally, it should have just been just two files I had to upload. map, and shared content. Yet because of this system, there are triple that number.

Why so many packs? Because every time I used GMpublish, it broke. It took too long, and broke. I’ve had this in the past, where moving to a slightly faster computer that was directly connected to the router resulted in a successful upload, after a further thirteen attempts that failed.

Internet speed is terrible in many areas, and these tools should not cut out so quickly, or at least be extended, or based on the file size of data being received.

And that’s besides the glaring issues of usability. The amount of hoops it takes to upload a Gmod addon is inexcusable when modding is it’s main selling point, and should have been automated and made user-friendly long, long ago.

Why on earth has this not been addressed? Why has the accessibility to the workshop, the most important part of Gmod, been so badly handled?

In other games, you simply press a button, and off the data goes, uploaded without issue, for the most part. Scribblenauts, Portal 2, Prison Architect and so many other games handle this perfectly well, with graphical interfaces to upload, and clear notifications of what is happening while uploading.

So, why does Gmod lag behind here, and why is no-one pushing for them to update these tools?

Sounds like you’re trying to upload a fucking gigabyte of content then.

From memory, it was large, but not massive. The compression got all the files to under 55MB, so size to the end user is hardly a problem.

The map itself is a 3D visualisation of Homestuck’s in-world webcomic, Sweet Bro and Hella Jeff. As such, I’ve had to add many overlays of the comic directly.

It’s worth noting, the maps have gained positive feedback across the board for their zany nature. I’m actually surprised at how successful they have been. Not a single negative comment. It’s actually kind of disappointing.

But that’s beside the point. I’ve optimised the maps the best I can, as well as cut down the asset packs as much as possible. With all that done, I couldn’t upload it all in one pack due to being timed out. I had to trial-and-error a max file size, then try to split the assets among those packs.

Almost 100% of the map is made of “original” textures, models and sounds, so of course it’s going to be larger than usual. I mean, will it kill the workshop to have a ~125MB content pack uploaded? Because that would be a hell of a lot better for all users who want to download my work. But my big issue is the arbitrary limit, based on the uploader’s Internet speed. That should have been fixed years ago.

So you are saying that you can upload a compressed 50 MB no problem, but your Internet can’t handle merging 11 MB and 2 MB? Or 11 and 23?

I wouldn’t say “no problem”. the 52MB file was the second I uploaded, and I really tried my best to get that one up. it had all the models, model textures, particles and misc textures in it. the small, 2gb one has all of the larger textures that were being a problem with the other files.

pre-compression, all files were roughly the same size, ~140-160MB, with the 2MB being the “runt”. pre-compression, it was 88MB, just under half of the largest upload, which was 184MB. It’s hardly something I could offload to the others. The contents of the GMA seemed to also have an affect on their successful upload, and how far the content could be compressed.

But besides that, the fact they need to download more than one content pack is not good at all. I want the people who play my maps to be able to download the content, then play it. there is no way in Gmod, aside from server-side, to download the content packs automatically. so all users need to download them manually, which means going to each pack and subscribing. If they even see that it needs packs in the first place. And that’s not even going near the issues of the tools interface. There needs to be a fluid way for anyone to be able to upload, but right now it’s all command-line, and has been since Gmod started using the workshop.

I understand your point about the lack of GUI applications to do this, but the reasons for this are:

  1. Automatisation of update process ( via .bat scrpts )
  2. Ability to create custom GUI wrappers for these tools

I personally use the .bat approach, but there are plenty other solutions made by the community.

As for uploading problems, GMod currently is constrained by outdated steam API, and updating it would require rewriting a substantial part of the addon system, both in-game and in the tools. But it is most definitely planned to switch GMod to the new system at some point in the future.

I can see why this openness and .bat script support would be useful for developers, certainly. But my problem is that it’s relying on the community to make it accessible, with no GUI to had. you need to go hunt out something that works, and who even knows which work at this point. For me, I’m using Workshopper 1.1, which has been the only one that’s ever worked, including using bat scripts. But that tool is very, very outdated, as are all of them. an official GUI or tool wouldn’t go amiss, and it would be nice to have a tool that actually works, and is updated to streamline the process.

This is the big problem though. “in the future”.

ambient_generic, the most basic sound entity there is, was broken for several months with no hotfix. I would put more money on Half Life 3 coming out before any of these problems are addressed, and I’m not even joking. I genuinely would.

Even now, I have a material type for a prop, to make it bouncy. a basketball. but even though I have done everything right on my end, it isn’t working. This is because an error with physenv.AddSurfaceData, which has been an issue for what must be a half year. but there has been no fix.

And I’ve yet to see VR sorted out in any capacity. I was excited to play Murder etc. with an Oculus, but I’ve been unable to, as they’ve still not fixed VR. that’s been broken for well over a year.

Frankly, since Rust came out, all technical support of Gmod has been sluggish and minimal. I adore Gmod, and the limitless possibilities it offers to users who buy it. but the support and bugfixing simply isn’t there, and that’s so frustrating, because these issues not only mess with my projects, but make the player’s experience worse off. I feel more and more that Gmod has been all but abandoned by the developers. The community’s still strong, which is what’s still pushing it’s popularity. but the developers really haven’t been there to fix things on their end. It’s disheartening, to say the least.

and, to swing it back to the topic, this has been an issue since it launched the workshop. before this, I had trouble uploading a 29GB compressed file. with the installation of Fibre Optic internet, that limit’s doubled, but the fact that it’s still tied to internet speed is terrible.

The old workshopper is the only thing you shouldn’t be using, its terribly out of date.

VR support will not be added into Garry’s Mod, and neither will Kinect 2.0.

It’s easy for you to say “half a year, no fix”, while I am the only one working on the game, and a lot of the problems are caused by the Source Engine. ( Like your physenv.AddSurfaceData, which has only 1 call per fire limitation due to how the physics engine handles it, and it is impossible to edit the physics engine for us )

I’m surprised nobody has made a nice GUI for it to be honest. It doesn’t seem like a difficult task. Has anyone tried?
I remember the GUI that garry made during the beta that was for workshop uploading. I can’t remember why it was stopped in the end.

There is a Java GUI application in the Releases subforum. There’s also gmosh which has shell integration with Windows.

The official wiki has all of this information.

It’s the only thing so far that works. all other methods do not work for me. Workshopper is literally my only tool that will get through mod uploading. Trust me, I’ve looked up all of these tools on and off the wiki. I’ve had a crack at uploading with them all, trying to overcome the publishing tools limits. None work for me, except Workshopper. If it’s as bad and outdated as you say, it’s really not good that it’s the only tool that can partially cope with this upload issue.

Then why was VR support half-implemented? working off of that info and VR commands in-game, I’ve been expecting VR to be added for ages. This is the first I’ve heard of VR never being in Gmod.

Well, there’s the problem. One person maintaining a massive game, in charge of all fixes and improvements. It’s hardly surprising that the updates take such large amounts of time. Like I said, it feels like the development team has all but abandoned Gmod since making Rust. I’m sort of shocked at just how much that rings true.

That’s not to critique any work you’ve done on fixing the game, but there should be a team of more than 1 person to update/bugfix a game as expansive as Gmod. Especially with how much popularity it’s getting. It’s practically the most played game on youtube.

As for the engine limitation, why is that command in the documentation, if it will never/cannot be fixed? Much like VR, that implies that there is a solution/a future update to fix the issue, and this is the very first I’ve heard that this issue is impossible to edit, and cannot be fixed.

VR was never implemented in GMod. Not half, not quarter. Anything that you can find of VR in GMod are leftovers from the Source Engine.

The function was added by Garry, but he didn’t realize what limitations there were, since other functions, like sound.Add, DO work this way.

[editline]7th September 2015[/editline]

Also “doesn’t work” is never helpful. If you want to be helpful, post actually useful information, like what happens when you try to upload something, your internet connection speeds, etc.

Ah, I see. Perhaps that’s what it was, then. Still, it gave me an impression that it would have VR at some point. hell, people have modded in Gmod VR with 3rd party applications/drivers.

Here’s some quotes I’ve got from previous threads on the issues

For larger files:


I need help with GMpublish. it keeps erroring whenever I try to upload.

I’ve tried everything. GMPU, Workshopper, GAC and even the old bat file/Gmad methods. nothing works.

The file has no illegal files, and it is under 300mb (276mb) uncompressed.
Whenever GMpublish tries to compress the gma, it instantaneously fails at the compressing stage, with no visible errors/prefixes. only “Compression -> failed!”, before the cmd window auto-closes

it seems it is able to upload files smaller that 150MB (uncompressed), but larger than that, and it fails.

I think it’s just timing me out, but what on earth is wrong here? and how do I fix this issue?

For uploading:


Well, just tried again, due to the supposed downtime of Steam last night, which would explain a fair bit if it were the cause of this issue.
nothing different. I put in the right info, it goes through, says it’s succeeded, and then, nothing happens. I’m at a loss as to what I am doing wrong, if anything!

EDIT: while all methods/gui’s so far have faked a “success”, Garry’s Workshop Publisher 1.0 has popped out an “Error updating 16”. does this help?
EDITx2: I ran it as an admin, and it went through now and then. sometimes no errors, sometimes error 16. the addon isn’t updating at all.

both of these issues are still present, and it’s spotty as to if it will error or not. The worst bit is the timeouts. it’s a roll of the dice, and most of the time it will fail.
the most frustrating thing is that it isn’t something I can even control. it’s pure chance and internet infrastructure, neither of which I can “correct”.