Go Fish server is acting very weird, need help!

Problem is solved, thanks a lot for the help! I let the text remain here in case someone else needs help with the same thing.

Hello Facepunchers!

I’m in a desperate need of help, I’ve been trying to get my Go Fish server to work for many days now but I seriously can’t figure out how to fix it.
The problem is that no one can use the Q-menu, see the score text or use the help menu! It works to type !rod, !hook and !bait and it works to fish but that’s it, nothing else works.
I do know how to get it to work but it’s not supposed to be done that way, everyone needs to install the Go Fish gamemode theirselves and then they have to create their own server with Go Fish running, after doing that, they can play on my server and Go Fish works perfectly fine.
But not many players wants to quit GMOD and do all that just to play on my fishing server so I need to find out how to fix it somehow.

My server is installed on a server computer with fiber connection and these are the things that are on it atm:

  • Go Fish (The SVN version)
  • ULX 3.40 + ULib
  • ASSMod 2.20
  • I’ve got fast download on the server also and yes, I have added the “sv_downloadurl”, “sv_allowdownload” and the “sv_allowupload” and it should work.

I think everything is installed correctly, I’ve tried to reinstall the server several times but it’s still the same, it won’t work.

I really need help with this because I’m all out of idéas, I don’t know what to do.

If you want to join the server and see for yourself how it is then here’s the IP and PW:

PW: abc

And one more thing, I don’t have any error messages or anything so don’t bother asking for them, and yes, I know… “How should we know what’s wrong when you can’t tell us more detailed information like error messages etc.” Well, I have no idéa, I’m just hoping that someone might know how to fix this cause I can’t be the only one with this problem, that would be very weird.

Please help me out with this problem guys! Thanks!

Turn off the fast dl, and see if it works. If it does then you most likely forgot to move the cache folder on to the fast dl.

Hey, thanks for the reply, what cache folder do you mean?

The dua cache folder in the garrysmod folder.

Thanks a lot patdaman45 and T3h raps13r, I got it to work thanks to you guys!!! :smiley:

evrytime i join a server by typing in “connect ip here” it says failed after four retries and could you maybe make the ip a link cause thats the only way because ive been desparteley looking for a gofish server.

(User was banned for this post ("dumb bump" - postal))