Going down to 1 FPS since the DX11 patch. Anyone else?

Normally, I don’t have too much of an issue with performance. Since procgen 7, I’ve dropped from the 60+ fps I was getting previously to a mostly steady 30 fps while running at max detail. I can squeeze our more if I lower detail, but I like the look of it so I deal with it. However, since the weekend updates that brought out DX11 and the other fixes, I’ve been having some issues that basically have made Rust unplayable.

When I load in, things seem fine in terms of performance, but I see a lot of graphical glitches and tearing. I find myself getting between 20 and 25 fps. While it’s annoying, it’s still somewhat playable. But after a while, the game will take a sharp downward dive and sit at 1 fps indefinitely. Doesn’t matter what I’m doing or where I am. Sometimes I’m out doing stuff, other times just parked in base crafting. There seems to be nothing in particular that triggers it. It just happens after a short tome of being logged in. The only way out is to alt+f4 and restart. I’ve tried logging off and back on without restarting the client, and it just loads up running at 1 fps.

I’ve tried running at lower resolutions, lowered details, running in DX9 mode, but it’s always the same. It doesn’t matter. I just drop to 1 fps and stay there.

Anyone else encounter this issue?

For reference:

i7 4770 @ 3.4 GHz
16 GB RAM
AMD R9 270, 2 GB

Yeah same sort of thing seems to happen one of my computers after about half an hour or so of playing, my other computer isn’t at all effected by it though

I’m having similar bugs and performance issues since dx11, colors abruptly changing (blue tint) etc . Interestingly, when I initiate the loader, the computer (mouse) runs VERY slowly for about 10 seconds. When the window comes up, everything is fine. Oddly, the next time I run a game (any game), SLI doesn’t engage when I know it should - I have to run the game loader again. It’s as if Rust is changing some sort of setting.

Another weird one, just before the dx11 update, I was experimenting with forcing SLI in rust. I was having some success and SLI was reporting to run on the visual indicator. Now if I run SLI on one screen, everything is ok (although there is no performance increase from 1 card so I don’t bother!). If I run SLI on surround mode (3 screens), no SLI - it’s a shame as this was showing some real promise and benefit before

How far will they go? 0,5fps next time guys.(

Same deal here. I’ll play around 30+ FPS, and it will suddenly tank to 1 FPS. Sometimes if I just stop moving and wait about 10-15 seconds it will recover, but not always. Sometimes I’ll have to force close Rust and relaunch. This has happened in the past but it happens a LOT more frequently now. Sometimes I’ll play for hours without an issue, other times I can’t go more than a few minutes.

FX8320E
16 GB DDR3
R9 280
Win7
SSD

I have attempted to replicate this by terrain, server, player count, time of day, system uptime … can’t find anything to make this consistently happen.

Ditto. Tried different things to reproduce it, but no go. Happens no matter what I’m doing and on all servers I’ve tried it on.

I’ve never had this problem before the recent updates though. Even though performance has been comparatively poor in the last 5-6 weeks since procgen7, at least I was at a pretty consistent frame rate. This dropping to 1 FPS is new totally new for me.

Lasted all of about 5 minutes this last login until my frame rate dropped to 1. I really hope this gets fixed, because this makes the game unplayable for me.

I am getting this as well but i never go below 30 fps. I just assumed it was a small bug that would be fixed in a coming update.
I guess i was wrong - Not a small bug.

I hope this gets fixed for you soon guys.

I’ll have a look around to see if i can find a temp fix

[editline]28th May 2015[/editline]

So i had a really quick look into this,

It seems that some people are noticing that there cpu cores are at 100% when using DX11 and not using the card memory.

Can you check if this is true with your systems.

This will help eliminate 1 possible cause

Possible solution is to completely delete DX11 and only install DX9

I’ll keep looking for other solutions in the mean time.

[editline]28th May 2015[/editline]

Can you post your DXDIAG

to get DxDiag

Press Windows Key + R.
Type DxDiag and press Enter.
In the DxDiag window, click Save All Information.
Name the file “dxdiag” and click Save.

you may be using custom drivers that are older than the current. Try to run a driver sweeper and clean out all of your AMD drivers in safe mode, you may be getting a conflict.

[editline]28th May 2015[/editline]

Hi

This is a fix for another game with the same issue.

Worth a shot

Check to see if your GPU clock speeds are idle while you’re ingame, you can use msi afterburner or other programs.

You could also try uninstalling the graphics card driver and reinstalling it.

I checked my CPU and GPU usage when I tanked to 1 fps last night. CPUs are normal, and using all of 300-ish MB on the video card.

Everything seems to work fine and I’m about 30 fps. Then I start getting bad graphical glitches and tearing and tank to 1 fps. Nothing but shutting down the game and restarting will fix it. But if I switch out of the game, everything else is working fine. Only Rust is affected.

The only other additional bit of intel I can provide is that this seems MORE likely to happen when I’m in fly mode as admin. I suppose it’s possible that there’s some texture coming into render distance that the game has a problem with, but I can’t imagine what this would be. I have confirmed that this is NOT as simple as “the mountain comes into render range” or “the satellite dish comes into render range”, nor can I replicate this by flying through the same area.

This also happens when I’m walking on the ground, so it’s definitely not limited to fly mode. It’s just MORE likely to happen when I’m zooming around.

Agreed. It happens quite randomly, but flying around in admin mode will accelerate it. Logged during my lunch break yesterday. Wanted to test something with C4, so flew out to an iceberg I do my admin playing on. FPS dropped to 1 almost as soon as I left my base flying.

I was logged in for about 45 mins last night. Didn’t dare leave the base, so just stayed inside crafting GP. Figured I would go outside and chop some trees. Made it out the front door (not in admin mode) and my fps dropped.

I can’t seem to replicate the issue no matter what I do, but I will confirm that flying does accelerate it.