GoldenForge - Hat and Trail store addon

Well, here’s the changelog for 1.1



--------------------------------------------------------------------------
- Version 1.1
--------------------------------------------------------------------------

Fixed loading in singleplayer.
Fixed admin give scrap metal menu amount option.
Cleaning up clientside hat entities better now, hopefully fixed a Opaque render crash.
Added trail color option.
Added "GoldenForge <version>" tags to sv_tags ConVar.
Added a info message when player spawns.
Optimized stuff.


Still have some more stuff to do, but currently busy with another thing.

Not sure if I can repeat this bug but when giving myself metals for the first time, it was fine, but then i realized I needed more for another hat, and then after that adding any amount of metals set me to MINUS metals.

Awesome, Thanks for the reply _Chewgum, One quick question, If I was to use this on my server, could I replace the name of GoldenForge?

I wouldn’t remove your information and such from the file’s but wanted to ask first just in case.

I don’t care how you use it, just put me in the credits.

Amazing! Releasing such a nice looking addon is something many people wouldn’t. Your a great person!

My problem is trying to give myself points i get the same error as the ones above, then i deleted everything in my addons folder and it still wont work?

I gotta a feeling alot of servers will be using this…

Always the best from Chewgum.

Can we look forward to an SVN anytime soon _Chewgum?

Guys points dont work for me

It works fine either you screwed up the Addon,You have an addon conflicting with it Or you installed it wrong

Well now im confussed because i know i installed it right, then i deleted everything in my addons folder so thats not the problem so

I want to get this to work with mysql but i cant :confused: other then that its awesome and i love it :]]]

pay chewgum to make an sql version, he will do it certainly for the right price.

So does anyone have any other reason on why it wont work?

I can’t get it to work either. I’m receiving this error:



[gf_client.lua:961] attempt to concatenate field 'scrapMetal' (a nil value)


It’s flooding my whole console.

P.S. I’m using DarkRP.

did you start the game on MULTIPLAYER?

Yes. I am using SRCDS on a dedicated server, running DarkRP as a gamemode.

I tried running it without DakRP - same error.
I tried removing all addons - same error.

I am getting the same error as munch and did the same things he did!

If/when someone finds a fix or one is released please pm me it.^^