Good lord i need help

This message comes up every damn time i try to get into gmod.“failed to lock vertex buffer in CMeshDX8::LockVertexBuffer” Here are my specs:OS Name Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DYLANS-LAPTOP
System Manufacturer Gateway
System Model MD2419U
System Type x64-based PC
Processor AMD Athlon™ X2 Dual-Core QL-65, 2100 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date Phoenix Technologies LTD 9A.30, 10/14/2008
SMBIOS Version 2.4
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = “6.1.7600.16385”
User Name Dylans-Laptop\Dylan
Time Zone Central Daylight Time
Installed Physical Memory (RAM) 3.00 GB
Total Physical Memory 2.75 GB
Available Physical Memory 1.09 GB
Total Virtual Memory 5.49 GB
Available Virtual Memory 3.26 GB
Page File Space 2.75 GB
Page File C:\pagefile.sys

Please list your graphics card too. Noone is going to help unless you post what we need to know.
Try this:

  • Right click Garry’s Mod on Steam
  • Choose Properties
  • In the window that appears, click Launch Options
  • In the text box that appears, type ‘-dxlevel 70’
  • Press OK to close all the boxes

Now try to run Garry’s Mod.

I had that exact same error message. Weirdly, it only happened to me with one map.

Also, whenever I would click “Launch Options” it said “these options are for advanced users only.” And then I clicked OK and the message disappeared, and I couldn’t set any launch options. WTH?

Lol,Anyways, I bypassed the error message by quickly saving on the problem map (that is, before the game crashed again), and then loading the map from the saved game.

Again, no other maps were an issue for me so I am doing fine.