Graphic bug in Linux during explosions and rocket launch

I posted this in steam’s forum but I will repost it here.

Graphical bug in LInux during explosions or rocket launch
The title nearly says it all. all explosions or rocket launch trails appear as a purple blob. I have included a link to a screen shot below.

My system info is;

Processor Information:
Vendor: GenuineIntel
CPU Family: 0x6
CPU Model: 0x2a
CPU Stepping: 0x7
CPU Type: 0x0
Speed: 3001 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 14.04.2 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.13.0-55-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11501000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release_2015-01-06

Video Card:
Driver: NVIDIA Corporation GeForce GT 730/PCIe/SSE2

Driver Version: 4.4.0 NVIDIA 331.113
OpenGL Version: 4.4
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1287
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 16.77" x 9.41" (19.21" diag)
42.6cm x 23.9cm (48.8cm diag)
Primary Bus: PCI Express 8x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Conexant CX20641

Memory:
RAM: 7968 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 461349 Mb
Largest Free Hard Disk Block: 288456 Mb

Installed software:

Recent Failure Reports:

Yep, same here on fedora 21

Yeah confirmed purple yuckiness on Ubuntu 15.04/nVidia as well

Yeah, this has been around for a while.
While we’re on the subject, the latest hotfix makes the game fail for me after clicking go on the launcher. Player.log says nothing about any errors.

Since i started up steam again since yesterday, there was another update to download. Still fucked for Linux. As said above, nothing in Player.log that looks any different from when it works normally. After hitting OK on the launcher it either goes to fullscreen (or not, tried selecting both) then just closes.
When I run it from the terminal all I get is this.


nail@Unicron:/steam_games/SteamApps/common/Rust$ ./rust
Set current directory to /steam_games/SteamApps/common/Rust
Found path: /steam_games/SteamApps/common/Rust/rust
Mono path[0] = '/steam_games/SteamApps/common/Rust/rust_Data/Managed'
Mono path[1] = '/steam_games/SteamApps/common/Rust/rust_Data/Mono'
Mono config path = '/steam_games/SteamApps/common/Rust/rust_Data/Mono/etc'
displaymanager : xrandr version warning. 1.4
client has 4 screens
displaymanager screen (0)(VGA-0): 1360 x 768
Using libudev for joystick management


Importing game controller configs
Aborted


Guess I’ll check back in a week or two…I’ve noticed lots of fucked shit people are reporting on the windows side and I know Linux gets no love whatsoever when that happens. I WOULD play Legacy to tide me over…but the Linux client was removed for that as well, GG!

Could you guys please get a Linux box to test on? Dual boot is so simple to set up even a Mac user could do it, and the OS doesn’t cost anything. FFS.

3 weeks later…still nothing.