Graphic Settings Are Acting Up

I haven’t played Gmod since I got my new card (GTX 660 ti) a few months ago. I just started it up, went into the video settings and noticed a few strange things. Color correction and motion blur are disabled, the shadows will only go up to medium, and I think the DirectX settings are being weird. I’m not really sure. Any ideas?

[editline]2nd July 2013[/editline]

Also, now that I’ve noticed, I’m having the same issues as this guy as well. Trees and Physgun flicker.

http://answers.yahoo.com/question/index?qid=20130620135118AA99K7v

A lot of people were/are having this problem. Notice your DirectX level is at 8.0.

Navigate to the properties for Garry’s Mod, and find “Set launch options” in the general tab.
Once you’re in there, add “-dxlevel 95” without the quotation marks.
Once you’ve launched the game once or twice while using that, ensure your hardware directx level is 9.0+ in your video options. Then you can remove that line from your launch options.
If you go without removing it, your settings will reset each time you launch Garry’s Mod.

That worked perfectly! Thank you so much.