Graphical settings screwed up after tinkering with Radeon Pro

http://cloud-3.steampowered.com/ugc/576760416524939485/257A56FCC0E73F7E0F392386800E6BDE1E4AD93C/

First I thought that my DirectX level must have reset, but it turns out it wasn’t that. Even tried setting it to 80, then back to 95.
I tried bumping up the AA quality, and a few other things on hl2.exe using Radeon Pro, but it just resulted in a blue screen as soon as I got into a server (I kinda went overboard with the options, and was expecting a crash, but not a blue screen).
Uninstalled, and attempted to play Garry’s Mod again, and was greeted with that sight above.
Tried reinstalling, and setting all of the options back to default so that it wouldn’t launch with anything added on, and it still does it.

Using a 7970 with Catalyst 13.12. I set all of the 3D Application settings back to the way they were (Use application settings) and Normal for the rest. Still no dice.

Ingame graphical settings http://cloud-3.steampowered.com/ugc/576760416525144495/7E64F077C1829C510211866DFFE1F872219E7DA8/.
CCC 3d Application settings http://i.imgur.com/Tee6zr9.png

Extra note - Blurred stuff becomes detailed once my camera is close to it. Player model does the same thing, but the detail isn’t what it used to be.

[editline]fix[/editline]

Had to use Radeon Pro to apply each global setting to the corresponding setting for the hl2.exe profile, and apply. Fixed it at least.