Graphics card not being recognized.

Just reinstalled Gmod after a year of inactivity, got all the fancy addons and whatnot, updated my nvidia drivers and whatever else I needed for other games, but I’ve discovered an error after launching.

Gmod does not seem to recognize my native resolution, will only let me choose DirectX 8.4c, and will not save my changes to settings when I restart the game.

450 GTS
AMD Athlon II X2 265 3.30 GHz
4 GB RAM
Windows 7 x64 Ultimate
1680x1050 Monitor

Haven’t had this problem with any other game.

If anyone can shed some light on my problem, it would be greatly appreciated.

Thanks for your time.

get a new PC


(User was banned for this post ("Consistent Shitposting  -fixed-" - Craptasket))

Are you fucking serious?

Jofnar, have you tried reinstalling GMod? Or just verifying the files?

I’ve gone through the usual processes: manually wrote out a config file, verified cache, defragged, reinstalled, etc.

Nothing seems able to convince Gmod that I’ve launched it before before.

Tried resetting your NVidia settings to default?