Graphics Problems

Hay i got gmod yesterday along with valve complete pack so i was downloading all the games and the first one i downloaded was half life 2 now i tested it and i keep having a lot of graphics problems when i shoot someone i see loads of little read squares and if i blow something up i see a sort of wire mesh appear all other the screen attached to the objects i just blew up so i thought it was the navmesh to i enabled the console to have a look at some of the options and looked for a wiremesh mode and there where some but then i enabled it and disabled it and it didd’nt make a difference so i restarted it and went through the options and some of the menues where messing up like overlapping each other so i ignored it and went into single player and opened up the spawn menu and most of it was transparent so i went out of it and looked at the ground and opened it up and it was working but every time i look at something with partials or a object and open it up its quite glitchy and the screen also messes up a lot with colours on the left side of the screen
i tried updating DirectX and it didn’t help so any help?

-Also note the game has become increasingly laggy for no reason i have quite a lot of addons but the graphical errors started before i even added any–
-annnnnnnnnnddd lowering the settings dont work-
-also i had gmod before this and it worked fine on this computer with no lag ect… but i reformated my computer to install BackTrack (Linux) again and lost every thing so i partitioned my hardrive and reinstalled steam and then bought gmod but this lag and the graphical errors are a real let down-

Here are some screenshots:

Menu overlapping
http://img6.imageshack.us/img6/1243/screenieli.th.jpg

Spawn Menu and menus failing
http://img709.imageshack.us/img709/5695/wtfyy.th.jpg

Annoying laggy boxes
http://img690.imageshack.us/img690/8634/wtfbox.th.jpg

What video card do you have?

Duel NVIDIA GeForce 8700M GT with the latest drivers
also i had gmod before and it worked fine so there is
no reason why it shouldn’t really work.

-edit-
I’m going to try enable SLI see if that makes a difference i doubt it though.
Nope no difference

-edit 1-
This is weird i have updated directX and yet it still says its at 0.8? Could this be it
http://img710.imageshack.us/img710/2307/screeniew.th.jpg

-edit 2-
Just to add there is no option to change multicore rendering i have dual core hm

Open advanced launch options from properties in Steam and type in “-dxlevel 90” without quotes

I tried it and i get this on start-up

Restart after that message comes up.

Fixed thanks guys still didn’t fix the lag problem though ha but never mind i cleaned up the addons folder and its still laggy but the graphics are fixed