Grass/Shrubs decals showing up weirdly

For some odd reason, the grass/shrubs decals are not displaying it properly as seen here in these screenshots.

http://cloud-3.steampowered.com/ugc/597039929518332189/FE1D8517017C82EED400A4CFCA7A73856D12E7A4/[/t]
[t]http://cloud-2.steampowered.com/ugc/597039929518328401/B243808D87395C40D20A17E2E145604B2C48AA00/

I have been trying find the source of this problem for quite some time, but I can’t really seem to find a solution to this.
Note that this problem is affecting all maps not just the ones displayed here in these screenshots.

This is caused by other mounted games overriding the textures. Try unmounting other games that are not required for this map.

Unfortunately, it didn’t work. I unmounted all of my games and it still shows the bugged decals.

Then the problem is that the map uses HL2 textures instead of whatever texture it is supposed to use. You could try extracting detail textures from whatever game that map is from to GMod, but that will break detail textures on HL2 maps, etc.

Like I already said in my original post, this problem is affecting all of the maps I am playing not just the ones displayed in the original post.

http://cloud-2.steampowered.com/ugc/597039929534154233/387704B6C029686F5FAEF09F74B9BBF27236FA5A/[/t]
[t]http://cloud-3.steampowered.com/ugc/597039929534157288/53A39AAEC1F8BFD661E0E45A0A054B7B8A17287F/[/t]
It even affects the original Half-Life 2 maps itself.
[t]http://cloud-3.steampowered.com/ugc/597039929534168455/052ECC3BC8A5881B52CA34D157E5ECA17127FA1D/[/t]
[t]http://cloud-3.steampowered.com/ugc/597039929534179057/99FF18FDF8D48A1E19AB809521F2A774A78D82BD/

Have you tried disabling all addons?

It will cause problems on all maps because all maps use same detail props and materials, but they differ in each game.

Well, I did that and it worked. Now, all I need to do is to find the addon(s) that’s causing this problem.

Look for ones with words “detail” and “fix”, I believe there’s one on workshop that fixes detail textures for TF2 maps.

I seem to see this error when it loads the bugged decals, but I don’t see it when I don’t have any addons.


GetSpriteAxes: Bad sprite type 1701080941

It’ll be a specific add-on causing it you just need to identify which one

I finally managed to find the problematic addon which is a map called rp_vuoristo and now everything back to normal.