Gravity Controller


Gravity Controller V3.0

Info:
[ul]
[li]Toggle gravity from constrained entities
[/li][li]Airbrake
[/li][li]Numpad-controlled too, for wire-hater (adv-fixed!)
[/li][li]Soundpitch changing
[/li][li]Now good-working Repositioning system (spacegate anyone?)
[/li][li]Fully Spacebuild-compatible
[/li][/ul]

[media]http://s3.garrysmod.org/img/dl/68232_2.jpg

Credits:
[ul]
[li]Malawar for his awesome Airbrake STool
[/li][li]SMILIE, friend and Lua-Helper :keke:
[/li][li]ColSheppard and Cebt for their models
[/li][li]Me for idea and code
[/li][/ul]

Bugs:
[ul]
[li]Hydraulics + No-Gravity: PARTY!
[/li][/ul]

Changelog:
[ul]
[li]V3.0:
[/li]Completely recoded that shitcode
Now really, REALLY spacebuild-compatible
A bunch of options added
[li]V2.1:
[/li]Added angular airbrake (no spinning around anymore),
also a checkbox to disable it (a litte bit buggy)
Fixed Duplicator (oh my god yay!)
[li]V2.0:
[/li]Added Cebt’s model, new modellist
Spacebuild-fix :smiley:
[li]V1.8:
[/li]Added a fucking repositioning system
[li]V1.6.5:
[/li]Little ADVDupe fix (compare number with nil)
STILL does not save sound/key!
[li]V1.6:
[/li]Spacebuild Fix (Can’t turn off gravity in space anymore, but i don’t know how to fix the thing goes into atmosphere and gravity turns on bug D:
Maybe spacebuild 3 fixes that)
Changed the Turn On/Off soundeffects. Now it changes status slowly, and no crappy shutdown sound anymore
Added ColSheppards “simple” Spacegate Powernode Model.
[li]V1.4:
[/li]Fixed some spelling mistakes :stuck_out_tongue:
[li]V1.3:
[/li]Added airbrake slider for the STool
Added loopsound-selection
[li]V1:
[/li]Now STool with numpad and model selection
Fixed loopsound working only for one SEnt at once
Added sound pitch change
[li]V0.7:
[/li]release
[/ul]

http://www.garrysmod.org/img/?t=dll&id=68232

Mango!

So…it’s like an advanced hoverball?

No it is not. It can not go up or down. Just disable gravity for prop. Make it stand on one direction. And make it be in one position. but it is still cool.

is there any way to make it where it only does the sound pitch. Want to use it on a train to give it an actual train sound, but it doesn’t work very well when the train lifts off the tracks.

hahaha, sorry i can just imagine the train lifting from the ground,
your idea with the sound should be easy to do with wiremod, just
(if your allowed to) copy the sounds from this addon to the servers sound folder and use wiremod’s sound emitter, that should do it…

ooh and Creator: nice script, i love this one, perfect for mineg traps or floating platforms and the like, this is a nice tool

reminds me, need to fix my current “elevator”

Good job on the script, hope to see more cool features for this handy tool
but for now, great job

thank you. I will try that.

just wire the airbrake input to a constant value of 0 and it will have no effect on your contraption.

I would love to remove the hoverball tool from our server and only have this.

The airbrake input for old adv’s does not work anymore, so replace it :keke:

Does it just disable gravity for the prop it’s welded to? Or anything else that it’s attached to?

For all constrained props, probably including ones constrained to ones constrained to it and so on so forth

That’s what I thought, but when I made a ship it sunk down on the side that I had all my life support stuff on.

Fucking spacebuild, you think you fixed it, but then another problem appears with an update from their side

I think it’s safe to say that this tool wins the game.

EDIT:
I found a bug: Weld 2 props together with a force weld, place a gravity controller on one of the props, activate it and break the weld, the one prop will continue to have no gravity, even when the controller is off and even when the controller is removed. No lua errors in console.

I know, if you remove the weld, the entity is not anymore in the “graventities-table”.
I have to find a way to turn its gravity off when constraint gets deleted.

Has anyone had any problems with this not working anymore after all the latest gmod updates? We can’t get it to work on our servers, and I can’t get it to work in Single Player. I even tried a fresh install of Garrysmod with no other addons.

The weird thing is, is that any dupes I have that already have it spawned work ok, but trying to spawn a new one with the gravity controller stool doesn’t work.

Doesn’t work for me or on my servers anymore after the recent updates either.

Same here.

Welt, could you please fix this?

I second that.
The problem is that the tool uses concommands which are now blocked.

But what for commands? Somehow when I want to select the STool, the whole STool-Command is blocked.