Grid problem in Source SDK (All games in general)

Hello boys and girls!

Lately I wanted to map again, but for some reason, my grid is in “3D”, if that’s what you can call it.

Well, the point is:

  1. I can’t see any models.
  2. When I zoom in (in the 2D grid, not the 3D I got), it’s like as if it’s in the 3D fully textured polygon-view. The 2D models are going by and such.
  3. I can’t zoom out more than just two blocks - I used to be able to see the entire map.

I really hope someone can explain some solution to me in details.

I appreciate your help so much!

Reset your sdk configurations.

Hmm, just tried once. Apparently it is only the configurations for Garry’s Mod which does not work. I check tutorials and everything which should make it work smoothly as it did back then, but yet it keeps doing this. I’ll try to post some pictures.

This is how it looks like. Notice how I have pressed on a tree, but can’t see it in the 3D view. All cameras are 100% zoombed out.

http://img834.imageshack.us/img834/1679/48581750.png

And here are my configurations. Well, I just did them this time with the default Half Life 2 name. I already tried with two different names: “Garry’s Mod” and “Gmod”, but yeah, I just decided to try with Half Life 2, don’t mind it.

http://img255.imageshack.us/img255/9158/asdoho.png

http://img594.imageshack.us/img594/62/aaaaaas.png

EDIT:

Sorry for the large pictures. How do I hide them in a spoiler or something?

Press W i think.

I assume you’ve already tried messing around with the options in the “2D views” and “3D views” settings?

Yes, I’ve tried everything you guys said :(.

You can use [noparse]
[/t][/noparse] to make it a thumbnail.
[t]https://dl.dropbox.com/u/3779442/Screenshots/2d_model_view.jpg

(left) Should turn on model view in the 3d view.

(right) make sure those are up because it will increase the render distance of models in the view port so you don’t see a bunch of yellow boxes.

And when navigating the 3d view port you should press Z ans use WASD to move. (its like using noclip)

I know all of this, and already tried it, unfortunately. I’ve been mapping for ~1 year already, and I know all of this stuff, the only problem I have is that my 2D view is in “3D”.

The Halloween update broke all versions of hammer for me, valve fixed the Source MP engine but all the others remain busted.

I get massive models and no grid, try Source MP to see if that’s also broke.

Well, unfortunately, it seems like Source MP is the only engine that works, if I configure it for GMod :frowning:

I solved this problem back in November by reinstalling SDK and using the CS:S default configuration. Some people don’t have it as default for some reason so if not, Google for a download.

Ha! Thank you so much! After I updated to Windows 8, Hammer wouldn’t show the grids and such. I thought it was a compatibility problem with windows. Again, thanks.