Ground texture is very bad help

Hi I’m playing Rust on “Fantastic” graphics setting, everything is perfect quality except the ground, also player models are blurry and look like plastic. I have everything in the options, including “Terrain Quality” at 100 (max)
If anyone could help I’d really appreciate it :slight_smile: