GTX 770

This game is unplayable on my ASUS GTX 770 … My temperatures sky rocket even on low resolutions. Any way to circumvent this ? Even when I pump the fan speeds up to 60-80% it is getting too hot… Thanks.

What are the rest of your specs? if you are lacking somewhere, your GPU must be taking a hit for the rest of your computer, because back on an earlier build of mine I could run it fine on a 760.

i7 4770k, 8 GB RAM on a Maximus IV Hero motherboard. My computer is more than fine, I get 600+ FPS in CS:GO and my temperatures are GREAT. I can run the game, I’m just worried for my temperatures, I dont feel comfortable letting my GPU sit at 90+º while I’m gaming for extended periods of time.

Crazy idea? Turn on vsync. See what happens.

My CPU does exactly what it always does, goes to about 54-58 celcius while gaming.

[editline]14th December 2013[/editline]

Hmm, that actually may work – haven’t thought to try that, is it possible to turn it off just in the game or should I just do it through my drivers?

Just a quick update, I can run around at about 55 celcius now where as before that was instantly hopping to 80+… This seems to work,t hanks for the suggestion… Any idea how to just turn it off in the game though maybe through launch options as I like to leave it “Off” for other games.

You need to upgrade your gpu to a NVidia 9800. The extra 0 should give you more performance.


(User was banned for this post ("Don't post if you're not going to help" - Craptasket))

Don’t be a dick.

[editline]14th December 2013[/editline]

Should be able to do it through your Nvidia Control Panel.

Just a quick update, I can run around at about 55 celcius now where as before that was instantly hopping to 80+… This seems to work,t hanks for the suggestion… Any idea how to just turn it off in the game though maybe through launch options as I like to leave it “Off” for other games.

Here’s my theory, and so far this seems to support it: Rust currently does not, or it’s relaxed or buggy, have a limiter on fps. Like, for example, you mention that you can get 600+ fps in CS:GO. You don’t really need that for a smooth gaming experience in any capacity but the gaming equivalent of gold-plated Monster HDMI audio cable audiophile territory, but normally, it won’t hurt anything so who cares.

But when pumping out 600+ fps takes up 100% GPU utilization, causing it to run roughly as hot as Satan’s left nut and risk the GPU’s overheat shutdown kicking in, maybe limiting the game to 120fps or something is a smarter idea. It’s not too uncommon in games during alpha/beta/early access (whatever you want to call it) stages to lack this limiter part or most of the time, because it interferes with testing and is another opportunity for extra bugs to get in the way.

Vsync manually clamps Rust to 60fps regardless of what the game wants to do.

Understood, I don’t run at that much in CSGO, I cap to 300 and all is fine. But good call, and thank you!

I have a gtx 770 and I don’t get this, if a game runs too good you’ll have to use vsync, best look at “Led visualizer” then check out what your gpu is doin + have speccy up

(if you play a very old game you’ll especially want vsync, or else you’ll get coil whine. Stalker does this in the menu for some reason, fraps wildly fluctuates between 1000-5000 and causes the computer to make a sound)

[editline]15th December 2013[/editline]

I’ve actually crashed my computer when I had two applications running with the framerates being uncapped

[editline]15th December 2013[/editline]

fps_max 60 in console for source games

or 80, better that way