gui:EnableScreenClicker(false)

I have a script that runs gui:EnableScreenClicker(true), but if I want to disable the cursor, gui:EnableScreenClicker(false) doesn’t work. How can I disable the cursor?

If there’s a panel on the screen that’s causing the trouble, try panel:KillFocus() I think.

I’m just trying to enable and disable the cursor, without any interaction with windows. Basically a key to toggle the mouse.

gui


.

EnableScreenClicker( bool )

When you use :, it passes the table gui as the first argument, which is always true as long as it isn’t false or nil. You don’t want that. Use a . instead.

Thanks! That fixed it!