GUIstudiomdl - X.smd does not exist

So I’m trying to get a .smd file which is a model made in blender, saved as a .3ds and exported to .smd from google sketchup (Plugins for everything else didnt work at all tried blender and XSI mod tool 7.5. plugins no work.) Named my .smd “Dragon-ref” and put it in a folder with a .qc file named Dragon, the code I put in it as is…
Code:
$modelname “props_sdk\dragon.mdl”
$body mybody “dragon-ref”
$staticprop
$surfaceprop combine_metal
$cdmaterials “models\props_sdk”

$sequence idle “myfirstmodel-idle.smd” loop fps 15

$collisionmodel “myfirstmodel-phys.smd” { $concave }

I didn’t mess around with the sequence and collision model lines because I was trying different .qc codes I found on How-to sites for the first problem I was trying to solve which is this
http://img704.imageshack.us/img704/4700/dragonerror.jpg
Valve sourcedocs are saying it looks for the smd in the same folder as the .qc which is where it is, why is the dragon.smd nonexistent?

you’ve got to put .smd after the smd name otherwise it goes crazy (I had this the other day :P)

so should be


$body mybody "dragon-ref.smd" 

You should also reference the source directory
$cd “path to the directory in which all your stuff is”

not needed if your QC is in the same place as the SMDs.

Thanks but I got it working with the Source SDK versions which I found about an hour after posting this. Since this is the first model I’m trying to get to work into source I thought I could get it to work as a gmod addon. I got a working spawnlist but my model is always invisible no checkerboard design or anything. I think this is related to the .mdl not knowing where to look for textures or which textures are the right ones.

I put cdmaterials on models/dragon and I put a .vtf and a .vmt for that texture file in garrysmod/garrysmod/models/dragon named dragon. Since cdmaterials looks for folders starting off from where the gameinfo.txt is.

make sure your VMTs have “VertexLitGeneric” at the top and not “LightmappedGeneric”.

If it couldn’t find the textures it would be pink and black checkers not invisible ^^

You also need to put the VMTs and VFTs in materials/models/dragon if you put models/dragon as the path.

Edit: Also if you need help setting up an addon I made this ages ago that may help you

http://www.garrysmod.org/img/?t=dll&id=71635

I tried that but VTFeditor just said “Error parsing VMT” with the error being “Error parsing material on line 3” (Expect open brace)

*I’m going to try making a new vmt

I suspect you’re missing a " on line 3.

AHH! If only you were there when I had my problem with exactly that. At first I thought it was incorrect UV mapping. Had so much trouble with it, but fortunately I realized my error… soon enough -.-

It happens to us all when starting out :stuck_out_tongue:

Also I must have said it 100s of times by now as i’ve been around since last year and its a regular issue, along with the 211 thing.

Im haveing the same problem I checked if I was missing the .smd but it was on there. im still getting error that says

entering C:\Users\CHRISP~1\Desktop\Modeling\modle.qc

************ ERROR ************
/male1-ref.smd.smd doesn’t exist.

it adds 2 .smds to the end and I tryed every thing but it does not work.

also heres my code

$modelname “modeling\male1.smd”
$body mybody “male1-ref.smd”
$surfaceprop flesh
$cdmaterials “models\males”

$sequence idle “male1-idle.smd” loop fps 5

$collisionmodel “male1-phys.smd” {$concave}
$mass 100.0