Gun shoots errors

after i got the most recent update, the guns i downloaded that worked before started to shoot out errors.
i tryed redownloading the sweps
i tried reinstalling gmod twice.
i looked everywhere for an answer and cant find one.

here is a video that shows what happens

sorry if the quality is bad

holy shit thats such horrible quality

Thats the bullet casings or some of them anyways,
I thought you meant it actually shot out errors lol

It seems the game isn’t rendering the various models properly. DO you have multi thread rendering enabled?

Im sorry i dont know what multi rendering is.

Do you have Counter Strike Source or CSS?

No i dont. But it all worked before.
The sweps said css wasnt required

can someone please help

Those are SHELLS, not BULLETS. Also, try deleting your crappy addons.

i have tryed doing that

Hmm. Try deleting the entire gmod folder, not the gmod/gmod folder, then deleting local content. That way, everything will leave.

i just finished trying that. i still get errors

help me

bump

Options -> Video -> Advanced -> Multicore Rendering.

Is it set to “Enabled”?

Also the addon itself might have broke. You’ll want to check out the SVN version, if you don’t have an SVN, google torisesvn. Install it, you won’t have to restart for it to work. Create a folder in addons. Right click, then hit SVN checkout. Copy and paste the svn url, then hit checkout. Make sure you delete the previous version of the addon.

It is enabled. Didnt work