gxml wont work?

Hello FP, today I tried using the gxml module, but after using it, any function like concommand.Add, Print, PrintTable etc wont work anymore, I used their example code



require("gxml")

PrintTable(XMLToTable[[
<note>
	<to>Tove</to>
	<from>Jani</from>
	<heading>Reminder</heading>
	<body>Don't forget me this weekend!</body>
</note>
]])


Nothing had been printed to the console(both client & serverside), then I tried putting print(“somestirng”) at the top, but not even that got printed(client & serverside), even if the file is empty but print + AddCSLuaFile(), what could cause the problem(since all my other addons work fine!)

[editline]5th September 2015[/editline]

the only working file is the shared.lua :confused:

Unrelated question (kinda): what are you using this for?

I want to retrieve steam group/user information, to return a list of specific users from my group(s).

[editline]5th September 2015[/editline]

Sure I could use the steam api for it, but I’d like to use the gxml, since I later on want to use other websites XML.

Most websites allow a JSON option too. I’m pretty sure the Steam Group pages work with JSON.
I’ve always used JSON with the Steam API.

Maybe this GXML thing is outdated? Where did you get this from?

http://facepunch.com/showthread.php?961117-gxml-A-XML-parser
Last post was august 2014.

Doesn’t look reliable. I’d look into alternatives.

well, atleast the example works for him, and in the thread is only positive feedback, so atleast the example should work for me :confused: