Hacker has messed up my mouse movements and made Gmod unplayable

EDIT: Hey guys, facepunch support helped me out, everything is fixed. They had me rename Gmod and then verify the cache, which fixed it all. Why deleting Gmod, then steam itself, didn’t fix it is beyond me, but everything works now so I’m happy. Thank you for all the help, even if it didn’t fix my issue, I really appreciate everyone going out of their way to try and help; you guys are awesome!

While in a TTT server a hacker showed up and messed things up. He did…something and made it so that when I try to look left or right, my camera jumps all over the place. I’ve tried uninstalling Gmod and even steam, but the problem persists. This only happens on Gmod. Does anyone know what they did, how I can fix it, anything?. I’ve spent 10+ hours looking around the internet, but no one seems to have had this issue before. Any information would be greatly appreciated.

Here’s what I get in the console every time I start up gmod

https://cdn.deskpro.com/files/603/8/7465CBMTXKKWDRCCAAR0-2013-09-01_00001.jpg

-left, -right

I assume that You have scanned the system for viruses and deleted the Garrysmod folder manually. Maybe you can clean your mouse or try running something thats on source too.

I don’t understand what you mean

[editline]2nd September 2013[/editline]

Correct, I have done both. All other source games are running just fine.

Does this happen on any other source games?

No, it does not

Check your autoexec.cfg in C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\garrysmod\cfg

To open it open notepad and drag the file in.

[editline]2nd September 2013[/editline]

Oh, and check your options, too, under “keyboard”.

I know this seems like simple shit but that stuff syncs to Steam Cloud and reapplies even if you reinstall the game.

If all else fails, you can delete the entire Garry’s Mod folder, turn off Steam Cloud and then reinstall. Do what Super said first.

autoexec.cfg is blank

Where do I find “keyboard”?

[editline]2nd September 2013[/editline]

Didn’t turn off steam cloud, if Super can’t resolve the issue I’ll give that a shot. Thank you very much in advance.

http://puu.sh/4hp1Y.png

Options in the main menu
Even if it seems normal I also suggest pressing “use defaults”

That was actually one of the first things I tried, multiple times actually.

Oh sonnava bitch.
Try code_gs’ suggestion then. Sorry I couldn’t help :frowning:
However if I get another idea I’ll be sure to suggest it.

Damn, oh well. Thanks for the help anyway, this hacker thoroughly fucked me over, it seems.

Have you tried asking other people who were in the same server at the same moment if they have the same issue with the mouse? Maybe someone of them found a way to fix this already.

I haven’t, I’ll give that a shot

Do You mind if I ask you what AV are you using? I would feel safer knowing that I don’t have the same :smiley:

AV?

Oh, anti-virus, got’cha. Norton as default, but I run malwarebytes when I think something is up. It usually fixes my problems, but I guess this one is different.

This sounds more like a configuration issue rather than a virus. Try wiping the contents of your cfg directory and then verify your local content.

Nah, it only happened directly after the guy told me “enjoy your new sensitivity”

This probably sounds stupid but you did check your mouse sensitivity, right?

Also what’s this?

http://puu.sh/4hAOl.png